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The video part of a media file cannot be played back when you use Windows Media Player 12 to play the media file in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

You use Windows Media Player 12 to play media files in a playlist in repeat mode. The video part of a media file cannot be played back but the audio part of the media file can be played back correctly.

Additionally, you may receive a dialog that links to one of the following errors:
  • Windows Media Player error C00D10D1: XVID MPEG-4 (XVID)

    Missing codec: XVID MPEG-4 (XVID).
  • Windows Media Player C00D11B1

    Windows Media Player can't play the file.
To resolve this issue, you have to restart Windows Media Player.


Note The issue only occurs when the playlist contains media files that are not supported by Media Foundation (MF). For example, this issues occurs when the playlist contains media files that are compressed by using DirectShow codecs.

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Cause

This issue occurs when a media file is not supported by MF. Windows Media Player 12 checks if the DirectShow video renderer can support the file. However, a memory leak issue occurs during the checking. Eventually, the player cannot create a Direct3D API for the graphics.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Media Player 12 installed on the omputer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTime
Wmp.dll12.0.7600.1656811,406,33608-Apr-201007:20
Wmplayer.exe12.0.7600.16568164,86408-Apr-201007:19
Wmploc.dll12.0.7600.1656812,625,40808-Apr-201007:17
Wmpplayer- ppdlic.xrm-msNot applicable3,12308-Apr-201007:30
Wmpps.dll12.0.7600.16568143,87208-Apr-201007:20
Wmpnetwk.exe12.0.7600.165681,121,28008-Apr-201007:19
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Wmp.dll12.0.7600.1656814,629,37608-Apr-201007:42x64
Wmplayer.exe12.0.7600.16568167,42408-Apr-201007:41x64
Wmploc.dll12.0.7600.1656812,625,92008-Apr-201007:39x64
Wmpplayer-ppdlic.xrm-msNot applicable3,12308-Apr-201007:57Not applicable
Wmpps.dll12.0.7600.16568476,67208-Apr-201007:42x64
Wmpnetwk.exe12.0.7600.165681,525,24808-Apr-201007:41x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about Windows Media Player error C00D10D1, visit the following Microsoft website: For more information about Windows Media Player error C00D11B1, visit the following Microsoft website:

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_microsoft-windows-mediaplayer- core_31bf3856ad364e35_6.1.7600.16568_none_0b58bdc4b05a5d77.manifest
File versionNot applicable
File size601,872
Date (UTC) 08-Apr-2010
Time (UTC)15:34
File nameX86_microsoft-windows-mediaplayer- wmpps_31bf3856ad364e35_6.1.7600.16568_none_ae794a7d9d3deaaf.manifest
File versionNot applicable
File size144,890
Date (UTC) 08-Apr-2010
Time (UTC)07:50
File nameX86_microsoft-windows-wmpnss- service_31bf3856ad364e35_6.1.7600.16568_none_0375c6782fd44550.manifest
File versionNot applicable
File size166,044
Date (UTC) 08-Apr-2010
Time (UTC)07:56
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_microsoft-windows-mediaplayer- core_31bf3856ad364e35_6.1.7600.16568_none_6777594868b7cead.manifest
File versionNot applicable
File size604,619
Date (UTC) 08-Apr-2010
Time (UTC)15:31
File nameAmd64_microsoft-windows-mediaplayer- wmpps_31bf3856ad364e35_6.1.7600.16568_none_0a97e601559b5be5.manifest
File versionNot applicable
File size144,892
Date (UTC) 08-Apr-2010
Time (UTC)08:52
File nameAmd64_microsoft-windows-wmpnss- service_31bf3856ad364e35_6.1.7600.16568_none_5f9461fbe831b686.manifest
File versionNot applicable
File size166,048
Date (UTC) 08-Apr-2010
Time (UTC)09:03
File nameWow64_microsoft-windows-mediaplayer- core_31bf3856ad364e35_6.1.7600.16568_none_71cc039a9d1890a8.manifest
File versionNot applicable
File size599,359
Date (UTC) 08-Apr-2010
Time (UTC)15:31

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Keywords: kbhotfixserver, kbautohotfix, kbsurveynew, kbexpertiseadvanced, kbqfe, kbfix, kb

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Article Info
Article ID : 981880
Revision : 2
Created on : 9/20/2018
Published on : 9/20/2018
Exists online : False
Views : 290