Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive an error message when you receive an EDI message in BizTalk Server 2006 R2


View products that this article applies to.

Symptoms

You use Microsoft BizTalk Server 2006 R2 to receive Electronic Data Interchange (EDI) or AS2 messages. When you receive an incoming message that has a null PortName field, an error message that resembles the following is logged in the Application log:

Event Type: Error
Event Source: BizTalk Server 2006 EDI
Event Category: None
Event ID: 4112
Description:
System.ArgumentNullException: Value cannot be null.
Parameter name: PortID
at Microsoft.BizTalk.Edi.Reporting.Common.Utilities.ValidateArgument(Object o, String parameterName, Boolean isEmptyStringValidationRequired)
at Microsoft.BizTalk.Edi.Reporting.InterchangeStatusActivity.ValidateParameters()
at Microsoft.BizTalk.Edi.Reporting.InterchangeStatusActivity.Create(Boolean isInterchangeAckExpectedOrGenerated, Boolean isFunctionalAcksExpectedOrGenerated, FunctionalGroupInfo[] fgiActivities

Additionally, you receive an error message when you view the Batch Status report in the EDI Status Reports section on the Group Hub page of the BizTalk Server Administration console.

↑ Back to the top


Cause

This issue occurs because the EDI disassembler in BizTalk Server 2006 R2 validates the PortName context property for values incorrectly. Therefore, when the value of the PortName property is null, the validation process fails.

↑ Back to the top


Resolution

The hotfix that resolves this problem is included in cumulative update package 2 for BizTalk Server 2006 R2 SP1.�

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2211420� Cumulative update package 2 for BizTalk Server 2006 R2 Service Pack 1

For more information about BizTalk Server 2006 R2 SP1 hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
974563� List of Microsoft BizTalk Server hot fixes that are included in BizTalk Server 2006 R2 Service Pack 1
You can also download the individual hotfix that only addresses the issue described in this KB article. You can find the individual hotfix information as below.

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have BizTalk Server 2006 R2 Service Pack 1 (SP1) to apply this hotfix.

Restart requirement

You do not have to restart the computer restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.edi.reporting.dll3.6.2213.1259,26411-May-201009:54x86

↑ Back to the top


More information

For more information about BAM Activities Created to Track EDI/AS2 Messages, visit the following Microsoft Developer Network (MSDN) website:For more information about BizTalk Server hot fixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907� Information on BizTalk Server hotfixes

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB981757, kbhotfixserver, kbsurveynew, kbexpertiseadvanced, kbautohotfix, kbqfe, kbbiztalk2006r2presp2fix

↑ Back to the top

Article Info
Article ID : 981757
Revision : 4
Created on : 9/3/2010
Published on : 9/3/2010
Exists online : False
Views : 289