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An application that invokes the configuration page for a scheduled task crashes after you change some task settings in Windows 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7 or Windows Server 2008 R2.
  • You run an application on this computer. The application relies on Task Scheduler to create or to change scheduled tasks.
  • You use the application to invoke the task configuration page for a scheduled task. You change some settings, and then click OK to exit the page.
In this scenario, the application crashes.

Note The application does not crash if you only change the program in the scheduled task to start from the configuration page.

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Cause

This issue occurs because of an error in Mstask.dll.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mstask.dll6.1.7600.20671209,92018-Mar-201018:45x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mstask.dll6.1.7600.20671238,08018-Mar-201018:34x64
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mstask.dll6.1.7600.20671420,35218-Mar-201018:12IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size1,459
Date (UTC)18-Mar-2010
Time (UTC)23:47
File nameX86_6c95ce613dffbb595878abc9e1514a0f_31bf3856ad364e35_6.1.7600.20671_none_02a85be0e83032cc.manifest
File versionNot applicable
File size722
Date (UTC)18-Mar-2010
Time (UTC)23:47
File nameX86_microsoft-windows-t..ompatibility-client_31bf3856ad364e35_6.1.7600.20671_none_5e6eed7ddeb185a3.manifest
File versionNot applicable
File size6,757
Date (UTC)18-Mar-2010
Time (UTC)19:24
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_01797abe51ac852b403f7aaa557fabab_31bf3856ad364e35_6.1.7600.20671_none_9291c5c80d47df5c.manifest
File versionNot applicable
File size1,092
Date (UTC)18-Mar-2010
Time (UTC)23:47
File nameAmd64_microsoft-windows-t..ompatibility-client_31bf3856ad364e35_6.1.7600.20671_none_ba8d8901970ef6d9.manifest
File versionNot applicable
File size6,761
Date (UTC)18-Mar-2010
Time (UTC)20:16
File nameUpdate.mum
File versionNot applicable
File size1,689
Date (UTC)18-Mar-2010
Time (UTC)23:47
File nameX86_microsoft-windows-t..ompatibility-client_31bf3856ad364e35_6.1.7600.20671_none_5e6eed7ddeb185a3.manifest
File versionNot applicable
File size6,757
Date (UTC)18-Mar-2010
Time (UTC)19:24
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_80248b481e18d2d997f825b201361813_31bf3856ad364e35_6.1.7600.20671_none_1c881f33a946a427.manifest
File versionNot applicable
File size1,090
Date (UTC)18-Mar-2010
Time (UTC)23:47
File nameIa64_microsoft-windows-t..ompatibility-client_31bf3856ad364e35_6.1.7600.20671_none_5e709173deaf8e9f.manifest
File versionNot applicable
File size6,759
Date (UTC)18-Mar-2010
Time (UTC)20:15
File nameUpdate.mum
File versionNot applicable
File size1,684
Date (UTC)18-Mar-2010
Time (UTC)23:47
File nameX86_microsoft-windows-t..ompatibility-client_31bf3856ad364e35_6.1.7600.20671_none_5e6eed7ddeb185a3.manifest
File versionNot applicable
File size6,757
Date (UTC)18-Mar-2010
Time (UTC)19:24

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Keywords: kbexpertiseinter, kbexpertiseadvanced, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbautohotfix, KB981710

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Article Info
Article ID : 981710
Revision : 1
Created on : 4/28/2010
Published on : 4/28/2010
Exists online : False
Views : 463