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Transferred data is corrupted or the data transfer stops between an IEEE 1394 device and a computer that is running Windows 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

You transfer isochronous data between a computer that is running Windows 7 or Windows Server 2008 R2 and an external IEEE 1394 device. For example, you transfer audio or video streams between the computer and an external IEEE 1394 device. However, the transferred data is corrupted or the data transfer stops intermittently.

This issue typically occurs when the data transfer is stopped and then is restarted. For example, the data transfer switches between video and static image capture.

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Cause

This problem occurs because of an error in the 1394ohci.sys driver.

When you transfer isochronous data between the computer and an external IEEE 1394 device, a resource handle is allocated and buffers are attached to the resource handle. When the data transfer is stopped and then is restarted, the buffers that are attached to the resource handle are used up. Then the 1394 client driver attaches more buffers to the resource handle and the data transfer resumes.

At the same time, the 1394ohci.sys driver updates the registers on the 1394 host controller. However, the 1394 host controller registers are not updated correctly. This behavior causes the data transfer process that is associated with the previously-attached buffers to be processed again before continuing with the data transfer process that is associated with the newly-attached buffers.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
1394bus.sys6.1.7600.1638554,78413-Jul-200923:51x86
1394ohci.sys6.1.7600.20671163,84018-Mar-201006:32x86
Ohci1394.sys6.1.7600.1638562,46413-Jul-200923:51Not applicable
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
1394bus.sys6.1.7600.1638568,09614-Jul-200900:06x64
1394ohci.sys6.1.7600.20671228,86418-Mar-201006:57x64
Ohci1394.sys6.1.7600.1638572,83214-Jul-200900:06x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
1394bus.sys6.1.7600.16385182,78414-Jul-200900:22IA-64
1394ohci.sys6.1.7600.20671510,97618-Mar-201006:28IA-64
Ohci1394.sys6.1.7600.16385172,03214-Jul-200900:22Not applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about isochronous data transfer for IEEE 1394 devices, visit the following Microsoft Developer Network (MSDN) Web site: For more information about how to set up isochronous transfer for IEEE 1394 devices, visit the following MSDN Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size1,441
Date (UTC)18-Mar-2010
Time (UTC)22:57
PlatformNot applicable
File nameX86_1394.inf_31bf3856ad364e35_6.1.7600.20671_none_fb961c1d8054a04e.manifest
File versionNot applicable
File size3,572
Date (UTC)18-Mar-2010
Time (UTC)22:59
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_1394.inf_31bf3856ad364e35_6.1.7600.20671_none_57b4b7a138b21184.manifest
File versionNot applicable
File size3,576
Date (UTC)18-Mar-2010
Time (UTC)23:04
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,449
Date (UTC)18-Mar-2010
Time (UTC)22:57
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_1394.inf_31bf3856ad364e35_6.1.7600.20671_none_fb97c0138052a94a.manifest
File versionNot applicable
File size3,574
Date (UTC)18-Mar-2010
Time (UTC)22:57
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,445
Date (UTC)18-Mar-2010
Time (UTC)22:57
PlatformNot applicable

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Keywords: kbexpertiseinter, kbexpertiseadvanced, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbautohotfix, KB981613

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Article Info
Article ID : 981613
Revision : 1
Created on : 4/15/2010
Published on : 4/15/2010
Exists online : False
Views : 370