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The scroll bar of a child control stops responding to the mouse click in an application on a computer that is running Windows Vista SP2 or Windows Server 2008 SP2 after you move a top level window of the application


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 SP2.
  • You do not use the Windows Classic theme.
  • You run an application that meets the following requirements:
    • A top level window of the application contains a child control that has a scroll bar.
    • The window does not have a standard title bar that is drawn to the non-client area of the window. However, the window has a custom title bar that is drawn to the client area of the window.
In this scenario, the scroll bar may stop responding to the mouse click after you move the window of the application.

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Cause

The code in the Uxtheme.dll keeps track of the coordinates of the scroll bar. They are used for hit-testing of the child control that has the scroll bar. After you move the window, the code is supposed to update the coordinates of the scroll bar. However, the coordinates of the scroll bar are not updated because the window does not have a standard title bar. Therefore, the scroll bar stops responding to the mouse click.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 SP2 on the computer. For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791� How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849� How to obtain the latest service pack for Windows Server 2008

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Uxtheme.dll6.0.6002.22367240,64018-Mar-201019:06x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Uxtheme.dll6.0.6002.22367317,44018-Mar-201019:01x64
Uxtheme.dll6.0.6002.22367234,49618-Mar-201019:07x86
For all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Uxtheme.dll6.0.6002.22367645,12018-Mar-201018:47IA-64
Uxtheme.dll6.0.6002.22367234,49618-Mar-201019:07x86

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Workaround

Workaround for Windows Vista and for Windows Server 2008

To work around this issue, use one of the following methods:

Method 1

Use a standard title bar in the window when you develop the application.

Method 2

Select Windows Classic theme. To do this, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Click Appearance and Personalization.
  3. Click Change the theme under Personalization.
  4. Select Windows Classic on the theme drop-down list.
  5. Click OK to apply the change.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size2,580
Date (UTC)19-Mar-2010
Time (UTC)10:31
PlatformNot applicable
File nameX86_66c35bcb80dd1c8671a7f53b5c5fc9c2_31bf3856ad364e35_6.0.6002.22367_none_50dec416b86c7a33.manifest
File versionNot applicable
File size695
Date (UTC)19-Mar-2010
Time (UTC)10:31
PlatformNot applicable
File nameX86_microsoft-windows-uxtheme_31bf3856ad364e35_6.0.6002.22367_none_a81ad5831cfddaca.manifest
File versionNot applicable
File size6,347
Date (UTC)19-Mar-2010
Time (UTC)05:01
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameAmd64_3c2ef623990234a989cb1e7a99634983_31bf3856ad364e35_6.0.6002.22367_none_e3efa01dddd1ac1f.manifest
File versionNot applicable
File size1,040
Date (UTC)19-Mar-2010
Time (UTC)10:31
PlatformNot applicable
File nameAmd64_microsoft-windows-uxtheme_31bf3856ad364e35_6.0.6002.22367_none_04397106d55b4c00.manifest
File versionNot applicable
File size6,369
Date (UTC)19-Mar-2010
Time (UTC)07:41
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,598
Date (UTC)19-Mar-2010
Time (UTC)10:31
PlatformNot applicable
File nameWow64_microsoft-windows-uxtheme_31bf3856ad364e35_6.0.6002.22367_none_0e8e1b5909bc0dfb.manifest
File versionNot applicable
File size7,449
Date (UTC)18-Mar-2010
Time (UTC)20:41
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameIa64_d60a06b426aeb9d2c3acb0b753ae13d0_31bf3856ad364e35_6.0.6002.22367_none_230456dc22e524ee.manifest
File versionNot applicable
File size1,038
Date (UTC)19-Mar-2010
Time (UTC)10:31
PlatformNot applicable
File nameIa64_microsoft-windows-uxtheme_31bf3856ad364e35_6.0.6002.22367_none_a81c79791cfbe3c6.manifest
File versionNot applicable
File size6,358
Date (UTC)18-Mar-2010
Time (UTC)20:14
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,922
Date (UTC)19-Mar-2010
Time (UTC)10:31
PlatformNot applicable
File nameWow64_microsoft-windows-uxtheme_31bf3856ad364e35_6.0.6002.22367_none_0e8e1b5909bc0dfb.manifest
File versionNot applicable
File size7,449
Date (UTC)18-Mar-2010
Time (UTC)20:41
PlatformNot applicable

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Keywords: KB981564, kbautohotfix, kbsurveynew, kbfix, kbhotfixserver, kbqfe, kbexpertiseadvanced, kbexpertiseinter

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Article Info
Article ID : 981564
Revision : 1
Created on : 4/14/2010
Published on : 4/14/2010
Exists online : False
Views : 317