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The Virtual Disk Service crashes when it exits in Windows Server 2003 SP2


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2003 Service Pack 2 (SP2), the Virtual Disk Service (VDS) may crash when the service tries to exit. When this issue occurs, an Error event that resembles the following is logged in the System log:
Event Type : Error
Event Source: Service Control Manager
Event Category: None
Event ID : 7034
Date: Date
Time: Time
User : N/A
Computer: Computer Name
Description: The Virtual Disk Service service terminated unexpectedly. It has done this <number> time(s).

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Cause

This issue occurs because the VDS incorrectly accesses some providers that are already unloaded during the exit process of the service.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2) on the computer.

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirement
Vds.exe5.2.3790.4678360,44810-Mar-201014:37x86SP2
Vdsutil.dll5.2.3790.467864,51210-Mar-201018:37x86SP2
For all supported x64-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirement
Vds.exe5.2.3790.4678633,34410-Mar-201002:50x64SP2
Vdsutil.dll5.2.3790.467896,76810-Mar-201002:50x64SP2
For all supported IA-64-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirement
Vds.exe5.2.3790.46781,179,13610-Mar-201002:49IA-64SP2
Vdsutil.dll5.2.3790.4678177,66410-Mar-201002:49IA-64SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB981544, kbprb, kbsurveynew, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter

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Article Info
Article ID : 981544
Revision : 1
Created on : 4/23/2010
Published on : 4/23/2010
Exists online : False
Views : 201