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"MAPI_E_NOT_ENOUGH_RESOURCES" error code when you run an application that calls the NspiQueryRows function


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You configure a Windows Server 2008-based domain controller as a global catalog server in a domain environment.
  • You run an application from another client computer to connect to the global catalog server.
  • The application calls the NspiQueryRows function.
In this scenario, the NspiQueryRows function fails and you receive the following error code:
MAPI_E_NOT_ENOUGH_RESOURCES
When this issue occurs, the application cannot query the information that is stored in Active Directory.

For example, you run Microsoft Office Outlook from a client computer to browse a name list in the Address Book in a domain environment. When you try to scroll down the name list in the Address Book, you receive an error message that resembles the following:
The operation failed due to a shortage in system resources
Therefore, you cannot view the complete name list in the Address Book.

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Cause

This issue is caused by a function related to Active Directory. The function uses a 255-byte array to store a search key. If the size of the search key is larger than 255 bytes, this issue occurs.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 or Windows Server 2008 Service Pack 2 (SP2) on the computer. Additionally, the Active Directory Domain Service role service must be installed on the computer. For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849� How to obtain the latest service pack for Windows Server 2008

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.600 1 . 22xxxWindows Server 2008SP1LDR
    6.0.600 2 . 22xxxWindows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntdsa.mofNot applicable227,72501-Apr-200918:56Not applicable
Ntdsai.dll6.0.6001.226521,950,72009-Mar-201016:02x86
Ntdsa.mofNot applicable227,72503-Apr-200920:49Not applicable
Ntdsai.dll6.0.6002.223581,950,72009-Mar-201016:08x86
For all supported x64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntdsa.mofNot applicable227,72501-Apr-200915:59Not applicable
Ntdsai.dll6.0.6001.226522,635,77609-Mar-201017:09x64
Ntdsa.mofNot applicable227,72503-Apr-200920:42Not applicable
Ntdsai.dll6.0.6002.223582,635,77609-Mar-201016:16x64

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Workaround

Workaround for Windows Server 2008

To work around this issue, configure a Windows Server 2003-based domain controller as a global catalog server. Then, run the application to connect to the global catalog server, and to query the information that is stored in Active Directory.

Note To work around this issue in Microsoft Outlook, disable the Use Cached Exchange Mode option in Outlook.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the NspiQueryRows function, visit the following Microsoft Developer Network (MSDN) Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size2,682
Date (UTC)10-Mar-2010
Time (UTC)07:55
PlatformNot applicable
File nameX86_447f4de3879a967477d87ce3afdf9f37_31bf3856ad364e35_6.0.6002.22358_none_6f275ccb8a2a72c3.manifest
File versionNot applicable
File size712
Date (UTC)10-Mar-2010
Time (UTC)07:55
PlatformNot applicable
File nameX86_7ae8cbffa26c63a72622482511ad6fdf_31bf3856ad364e35_6.0.6001.22652_none_67f2fbc465305e6c.manifest
File versionNot applicable
File size712
Date (UTC)10-Mar-2010
Time (UTC)07:55
PlatformNot applicable
File nameX86_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.0.6001.22652_none_f11bd92dd267148f.manifest
File versionNot applicable
File size12,574
Date (UTC)09-Mar-2010
Time (UTC)18:17
PlatformNot applicable
File nameX86_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.0.6002.22358_none_f3084cd1cf8801bd.manifest
File versionNot applicable
File size12,574
Date (UTC)09-Mar-2010
Time (UTC)18:08
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameAmd64_111bb94d78721ed604eb9077faa03bae_31bf3856ad364e35_6.0.6001.22652_none_4cffa953ced405b8.manifest
File versionNot applicable
File size716
Date (UTC)10-Mar-2010
Time (UTC)07:55
PlatformNot applicable
File nameAmd64_9cfc2ec3317b44bba3aecc84175519c4_31bf3856ad364e35_6.0.6002.22358_none_8bb6b373daea74e3.manifest
File versionNot applicable
File size716
Date (UTC)10-Mar-2010
Time (UTC)07:55
PlatformNot applicable
File nameAmd64_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.0.6001.22652_none_4d3a74b18ac485c5.manifest
File versionNot applicable
File size12,632
Date (UTC)09-Mar-2010
Time (UTC)19:15
PlatformNot applicable
File nameAmd64_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.0.6002.22358_none_4f26e85587e572f3.manifest
File versionNot applicable
File size12,632
Date (UTC)09-Mar-2010
Time (UTC)18:11
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,702
Date (UTC)10-Mar-2010
Time (UTC)07:55
PlatformNot applicable

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Keywords: kbexpertiseinter, kbexpertiseadvanced, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbautohotfix, KB981465

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Article Info
Article ID : 981465
Revision : 1
Created on : 4/28/2010
Published on : 4/28/2010
Exists online : False
Views : 460