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An Office application does not open or save documents from a SharePoint site on a client computer that is running Windows Vista SP2 or Windows Server 2008 SP2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a SharePoint site that is configured to require client certificate authentication.
  • You have a client computer that is running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 Service Pack 2 (SP2).
  • You use a Microsoft Office application on the client computer to process a document that is hosted on the SharePoint site. The Microsoft Office application registers the DavAuthCallback callback function to support forms-based authentication.
In this scenario, the Office application may not able to open or save the document.

Notes
  • This issue only affects some Microsoft Office applications. For example, 2007 Microsoft Office suite Service Pack 2 applications that have the Office 2007 Cumulative Update 968765 installed are affected.
    968765� Office 2007 Cumulative Update for April 2009
  • The issue also affects all the other Web Distributed Authoring and Versioning (WebDAV) client applications that use the DavAuthCallback callback function. In this situation, the issue occurs when these WebDAV client applications try to access files on a WebDAV site that requires client certificate authentication.

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Cause

The issue occurs because of an error in WebDAV redirector. Microsoft Office applications register the DavAuthCallback callback function so that the applications can use this function to prompt the user for credentials. This mechanism enables Office applications to support forms-based authentication. However, if an Office application tries to access a WebDAV site that is configured to use client certificate authentication, the function does not work correctly. The DavAuthCallback callback function does not prompt a client certificate dialog box for the user. Therefore, authentication fails and the Office application cannot open or save documents from that WebDAV site.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 Service Pack 2 (SP2).

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791� How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849� How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Davclnt.dll6.0.6002.2235761,44008-Mar-201016:00x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Davclnt.dll6.0.6002.2235782,43208-Mar-201015:46x64

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Workaround

Workaround for Windows Vista and for Windows Server 2008

To work around this issue, do not use client certificate authentication on the SharePoint site.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about WebDAV and the DavAuthCallback callback function, visit the following Microsoft Developer Network (MSDN) Web sites: For more information about authentication methods in SharePoint, visit the following Microsoft Developer Network (MSDN) Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot Applicable
File size2,211
Date (UTC)09-Mar-2010
Time (UTC)05:54
PlatformNot Applicable
File nameX86_18730c24b27b94b52820ac50997853a5_31bf3856ad364e35_6.0.6002.22357_none_60560778382ed0a1.manifest
File versionNot Applicable
File size709
Date (UTC)09-Mar-2010
Time (UTC)05:54
PlatformNot Applicable
File nameX86_microsoft-windows-webdavredir-davclient_31bf3856ad364e35_6.0.6002.22357_none_960e73da68a55e4b.manifest
File versionNot Applicable
File size5,069
Date (UTC)08-Mar-2010
Time (UTC)17:53
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameAmd64_79e8d6af9bddac13f85a45e28a133987_31bf3856ad364e35_6.0.6002.22357_none_a607f592e63af07f.manifest
File versionNot Applicable
File size1,066
Date (UTC)09-Mar-2010
Time (UTC)05:54
PlatformNot Applicable
File nameAmd64_microsoft-windows-webdavredir-davclient_31bf3856ad364e35_6.0.6002.22357_none_f22d0f5e2102cf81.manifest
File versionNot Applicable
File size5,087
Date (UTC)08-Mar-2010
Time (UTC)17:39
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,391
Date (UTC)09-Mar-2010
Time (UTC)05:54
PlatformNot Applicable
File nameX86_microsoft-windows-webdavredir-davclient_31bf3856ad364e35_6.0.6002.22357_none_960e73da68a55e4b.manifest
File versionNot Applicable
File size5,069
Date (UTC)08-Mar-2010
Time (UTC)17:53
PlatformNot Applicable

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Keywords: kbprb, kbsurveynew, kbautohotfix, kbexpertiseinter, kbhotfixserver, kbfix, kbqfe, KB981399

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Article Info
Article ID : 981399
Revision : 1
Created on : 4/14/2010
Published on : 4/14/2010
Exists online : False
Views : 570