Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Some paths that are used to access LUNs may not be available when you use Device Specific Module for MPIO in Windows Server 2008 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a server that is running Windows Server 2008 or Windows Server 2008 R2.
  • You connect the server to a SAN by using Microsoft Multipath I/O (MPIO).
  • You use Microsoft Device Specific Module (DSM) for MPIO.
  • You assign at least one logical unit number (LUN) that is located on the SAN to the server.
  • The LUNs go offline. The time that these LUNs are offline is longer than the PDORemovePeriod timer value that is set in the registry.
  • The LUNs come back online.
In this scenario, some paths that are used to access the LUNs may not be available.

↑ Back to the top


Cause

This issue occurs because DSM for MPIO cannot claim all paths when the LUNs are brought back online. Specifically, DSM may be unable to run a Report Target Port Groups command when the LUNs are claimed.

Note This hotfix adds an additional condition under which DSM retries the Report Target Port Groups command. Specifically, DSM retries the command if the command returns a SCSI check condition.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows Server 2008 R2
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    1.
    22xxx
    Windows Server 2008SP1LDR
    6.0.600
    2.
    22xxx
    Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxx version number.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Msdsm.sys6.0.6001.2267992,04028-Apr-201017:15x86
Msdsm.sys6.0.6002.2239392,03228-Apr-201018:25x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Msdsm.sys6.0.6001.22679111,50428-Apr-201017:51x64
Msdsm.sys6.0.6002.22393111,48828-Apr-201018:32x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Msdsm.sys6.0.6001.22679275,85628-Apr-201017:35IA-64
Msdsm.sys6.0.6002.22393275,84028-Apr-201018:05IA-64
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Msdsm.sys6.1.7600.20671140,68818-Mar-201018:37x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Msdsm.sys6.1.7600.20671348,04018-Mar-201018:14IA-64

↑ Back to the top


Workaround

To work around this issue, restart the computer.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about the PDORemovePeriod timer value, visit the following Microsoft TechNet Web site:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Amd64_msdsm.inf_31bf3856ad364e35_6.1.7600.20671_none_26cca3b70e55b0ef.manifestNot applicable2,07918-Mar-201020:19Not applicable
Package_for_kb981379_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNot applicable1,86018-Mar-201022:57Not applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ia64_msdsm.inf_31bf3856ad364e35_6.1.7600.20671_none_caafac2955f648b5.manifestNot applicable2,07718-Mar-201020:18Not applicable
Package_for_kb981379_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mumNot applicable1,44418-Mar-201022:57Not applicable

↑ Back to the top


Keywords: kb, kbexpertiseadvanced, kbfix, kbautohotfix, kbsurveynew, kbqfe, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 981379
Revision : 2
Created on : 9/20/2018
Published on : 9/21/2018
Exists online : False
Views : 259