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"Table <Table No.> does not exist" error message when you run the "Synchronize All Logins" function in Microsoft Dynamics NAV


Symptoms

Consider the following scenario:
  • You upgrade a Microsoft Dynamics NAV database. However, you do not upgrade the database roles.

    Note One or more roles in the current database include permissions for tables that do not exist in the upgraded database.
  • You run the Synchronize All Logins function in Microsoft Dynamics NAV 2009 or in Microsoft Dynamics NAV 5.0.
In this scenario, you receive the following error message:
Table Table No. does not exist

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Cause

This problem occurs when the following conditions are true:
  • A security role in Microsoft Dynamics NAV is assigned to a user.
  • The security role includes permissions for a table that does not exist in the database.

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Resolution

To resolve this problem, delete the table that is indicated in the error message from the Permission table. To do this, follow these steps:
  1. On the Tools menu, point to Security, and then click Roles.
  2. Select any role, and then click Role, Permissions.
  3. On the Permissions table, click View, and then click Show All to show all permissions.
  4. Select the Object ID column for any record.
  5. Click View, click Field Filter, type the table number that is mentioned in the error message, and then click OK.
  6. Delete all records for the table that is mentioned in the error message.

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Keywords: kbmbsdatabaseandplatforms, kbsurveynew, kbmbspartner, kbexpertisebeginner, kbtshoot, kbmbsmigrate, kbprb, kbexpertiseinter, kb

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Article Info
Article ID : 981310
Revision : 1
Created on : 1/7/2017
Published on : 8/4/2011
Exists online : False
Views : 103