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Management servers or assigned agents unexpectedly appear as unavailable in the Operations Manager console in Windows Server 2003 or Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install a Microsoft System Center Operations Manager root management server or a Microsoft System Center Operations Manager management server on a computer that is running Windows Server 2003 or Windows Server 2008.
  • You open the System Center Operations Manager console to view management servers and assigned agents.
In this scenario, either management servers or the assigned agents may be displayed as unavailable even though the health state of the management servers is displayed as healthy.

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Cause

This issue occurs because the database that is used by the health state is corrupted. This database corruption is caused by an issue in the storage engine of the jet database that is hosted on Windows.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2) or Windows Server 2008 Service Pack 2 (SP2)on your computer. For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
For all supported x86-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Esent.dll5.2.3790.46741,044,48003-Mar-201007:46x86
For all supported x64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Esent.dll5.2.3790.46742,367,48802-Mar-201016:08x64SP2Not applicable
Wesent.dll5.2.3790.46741,044,48002-Mar-201016:08x86SP2WOW
For all supported IA-64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Esent.dll5.2.3790.46742,771,45602-Mar-201016:07IA-64SP2Not applicable
Wesent.dll5.2.3790.46741,044,48002-Mar-201016:07x86SP2WOW
Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 1 . 22xxxWindows Server 2008SP1LDR
    6.0.600 2 . 22xxxWindows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Esent.dll6.0.6002.223521,459,71202-Mar-201016:25x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Esent.dll6.0.6002.223522,506,75202-Mar-201016:20x64
Esent.dll6.0.6002.223521,459,71202-Mar-201016:25x86
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Esent.dll6.0.6002.223523,590,14402-Mar-201016:11IA-64
Esent.dll6.0.6002.223521,459,71202-Mar-201016:25x86

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Workaround

To work around the issue, delete the health service state directory on the computer (root management server, management server, or agent) that is affected. To do this, follow these steps:
  1. Stop the following service, as appropriate for your version of System Center Operations Manager:

    On System Center Operations Manager 2007 SP1: Stop the OpsMgr Health service.

    On System Center Operations Manager 2007 R2: Stop the System Center Management service.
  2. Locate the installation directory for OpsMgr in the following path:
    SystemDrive\Program Files\System Center Operations Manager 2007
  3. Delete the Health Service State directory.
  4. Restart the service.
After you restart the service, the database is rebuilt.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
File namePUpdate.mum
File versionNot applicable
File size3,068
Date (UTC)03-Mar-2010
Time (UTC)00:33
PlatformNot applicable
File nameX86_df248edd35b00bbea7ac780e9860ff5a_31bf3856ad364e35_6.0.6002.22352_none_e537e544bf459e1e.manifest
File versionNot applicable
File size716
Date (UTC)03-Mar-2010
Time (UTC)00:33
PlatformNot applicable
File nameX86_microsoft-windows-e..estorageengine-isam_31bf3856ad364e35_6.0.6002.22352_none_f420500a4276641d.manifest
File versionNot applicable
File size8,529
Date (UTC)02-Mar-2010
Time (UTC)18:08
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Server 2008
File nameAmd64_e4bc32d43770ced3e127c751ea740f2d_31bf3856ad364e35_6.0.6002.22352_none_842b7c930188fc06.manifest
File versionNot applicable
File size1,080
Date (UTC)03-Mar-2010
Time (UTC)00:33
PlatformNot applicable
File nameAmd64_microsoft-windows-e..estorageengine-isam_31bf3856ad364e35_6.0.6002.22352_none_503eeb8dfad3d553.manifest
File versionNot applicable
File size8,549
Date (UTC)02-Mar-2010
Time (UTC)18:01
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,092
Date (UTC)03-Mar-2010
Time (UTC)00:33
PlatformNot applicable
File nameX86_microsoft-windows-e..estorageengine-isam_31bf3856ad364e35_6.0.6002.22352_none_f420500a4276641d.manifest
File versionNot applicable
File size8,529
Date (UTC)02-Mar-2010
Time (UTC)18:08
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_bc65de72a8f65f62bd07a78bb51cc934_31bf3856ad364e35_6.0.6002.22352_none_51c9044d719e7ffe.manifest
File versionNot applicable
File size1,078
Date (UTC)03-Mar-2010
Time (UTC)00:33
PlatformNot applicable
File nameIa64_microsoft-windows-e..estorageengine-isam_31bf3856ad364e35_6.0.6002.22352_none_f421f40042746d19.manifest
File versionNot applicable
File size8,539
Date (UTC)02-Mar-2010
Time (UTC)17:40
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,247
Date (UTC)03-Mar-2010
Time (UTC)00:33
PlatformNot applicable
File nameX86_microsoft-windows-e..estorageengine-isam_31bf3856ad364e35_6.0.6002.22352_none_f420500a4276641d.manifest
File versionNot applicable
File size8,529
Date (UTC)02-Mar-2010
Time (UTC)18:08
PlatformNot applicable

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Keywords: kbfix, kbautohotfix, kbexpertiseadvanced, kbsurveynew, kbqfe, KB981263

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Article Info
Article ID : 981263
Revision : 4
Created on : 10/6/2011
Published on : 10/6/2011
Exists online : False
Views : 371