Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Stop error message when you run an application that transfers data by using the UDP protocol in Windows Server 2008 R2 or in Windows 7: "Stop error code 0x0000007F (UNEXPECTED_KERNEL_MODE_TRAP)"


View products that this article applies to.

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

↑ Back to the top


Symptoms

Consider the following scenario:
  • You install some UDP traffic-related filter drivers on a computer that is running Windows Server 2008 R2 or Windows 7. For instance, you install a UDP traffic-related file driver when you install a firewall application on the computer.
  • You run an application that transfers data by using the UDP protocol on the computer. 
In this scenario, you may receive the following Stop error message:
STOP: 0x0000007F (0x0000008, parameter2, parameter3, parameter4) UNEXPECTED_KERNEL_MODE_TRAP
Note
  • The parameters that are after the "0x0000008" parameter in this error message vary, depending on the configuration of the computer.
  • Not all 0x0000007F Stop errors are caused by this issue.
  • This issue occurs more frequently on a computer that is running a 64-bit version of Windows Server 2008 R2 or of Windows 7.

↑ Back to the top


Cause

This issue occurs because the operating system cannot allocate enough stack space for a UDP packet when there are many kernel filter driversinstalled.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Fwpkclnt.sys6.1.7600.16385187,47214-Jul-200901:20x86
Tcpip.sys6.1.7600.207191,288,58426-May-201010:58x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Fwpkclnt.sys6.1.7600.16385288,33614-Jul-200901:47x64
Tcpip.sys6.1.7600.207191,889,66426-May-201011:43x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Fwpkclnt.sys6.1.7600.16385482,89614-Jul-200901:58IA-64
Tcpip.sys6.1.7600.207193,778,44026-May-201010:26IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_c96b96b1e38f007ee9bb61106d483d68_31bf3856ad364e35_6.1.7600.20719_none_d21c3ca5a196a7cb.manifest
File versionNot applicable
File size702
Date (UTC)26-May-2010
Time (UTC)14:54
PlatformNot applicable
File nameX86_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7600.20719_none_b3cdbb8ee09b0f6b.manifest
File versionNot applicable
File size3,780
Date (UTC)26-May-2010
Time (UTC)14:57
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_350132bb80877bde8f0ab4da1b058420_31bf3856ad364e35_6.1.7600.20719_none_ad48653da6b3b3bb.manifest
File versionNot applicable
File size706
Date (UTC)26-May-2010
Time (UTC)14:54
PlatformNot applicable
File nameAmd64_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7600.20719_none_0fec571298f880a1.manifest
File versionNot applicable
File size3,784
Date (UTC)26-May-2010
Time (UTC)14:59
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_dc3bfc171309ec54a957c0fe1661f6ae_31bf3856ad364e35_6.1.7600.20719_none_6c7258f47afa45d9.manifest
File versionNot applicable
File size704
Date (UTC)26-May-2010
Time (UTC)14:54
PlatformNot applicable
File nameIa64_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7600.20719_none_b3cf5f84e0991867.manifest
File versionNot applicable
File size3,782
Date (UTC)26-May-2010
Time (UTC)14:54
PlatformNot applicable

↑ Back to the top


Keywords: kbmdd, consumerwin7track, kbhotfixserver, kbautohotfix, kbsurveynew, kbexpertiseadvanced, kbqfe, kbfix, kb

↑ Back to the top

Article Info
Article ID : 981180
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2014
Exists online : False
Views : 198