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"The home folder could not be created" remote desktop error in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You open the Properties dialog box for a user account on a domain controller that is running Windows Server 2008 R2.
  • On the Remote Desktop Services user profile tab, you set the Remote Desktop Home Folder attribute to an existing shared folder.
  • You click Apply or OK.
In this scenario, you receive the following error message:
The home folder could not be created because: The filename, directory, name, or volume label syntax is incorrect.
If you click Apply or OK again, no error message is returned. Additionally, the setting is not saved.

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Cause

This issue occurs because the Remote Desktop Services Extension driver (Tsuserex.dll) does not save the user settings when the driver encounters an "ERROR_ALREADY_EXISTS" error.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 on the computer. Additionally, the computer must have the Remote Desktop Service role installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tsuserex.dll6.1.7600.20661147,45608-Mar-201001:44x64
Tsuserex.dll6.1.7600.20661128,51206-Mar-201009:46x86
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tsuserex.dll6.1.7600.20661301,05606-Mar-201008:08IA-64
Tsuserex.dll6.1.7600.20661128,51206-Mar-201009:46x86

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Workaround

Workaround for Windows Server 2008 R2

To work around this issue, re-create or rename the folder, and then try to set the Remote Desktop Home Folder attribute again.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
For more information about the Remote Desktop Services, visit the following TechNet Web sites:

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_de09bf1e76f6547bc295964370949f4b_31bf3856ad364e35_6.1.7600.20661_none_ab8c10dc9878c6ad.manifest
File versionNot applicable
File size720
Date (UTC)08-Mar-2010
Time (UTC)23:11
PlatformNot applicable
File nameAmd64_f859f6daa3a42fc9748a7bd6e3f62fb4_31bf3856ad364e35_6.1.7600.20661_none_061a88b729189f7f.manifest
File versionNot applicable
File size722
Date (UTC)08-Mar-2010
Time (UTC)23:11
PlatformNot applicable
File nameAmd64_microsoft-windows-t..vices-userextension_31bf3856ad364e35_6.1.7600.20661_none_4f5af25a1628780c.manifest
File versionNot applicable
File size12,880
Date (UTC)08-Mar-2010
Time (UTC)02:18
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,671
Date (UTC)08-Mar-2010
Time (UTC)23:11
PlatformNot applicable
File nameX86_microsoft-windows-t..vices-userextension_31bf3856ad364e35_6.1.7600.20661_none_f33c56d65dcb06d6.manifest
File versionNot applicable
File size12,876
Date (UTC)06-Mar-2010
Time (UTC)10:23
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_d4f5b53cc2f3da274fc9f3f31143e2ad_31bf3856ad364e35_6.1.7600.20661_none_cc218e2eb807362f.manifest
File versionNot applicable
File size1,082
Date (UTC)08-Mar-2010
Time (UTC)23:11
PlatformNot applicable
File nameIa64_microsoft-windows-t..vices-userextension_31bf3856ad364e35_6.1.7600.20661_none_f33dfacc5dc90fd2.manifest
File versionNot applicable
File size12,878
Date (UTC)06-Mar-2010
Time (UTC)11:20
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,446
Date (UTC)08-Mar-2010
Time (UTC)23:11
PlatformNot applicable
File nameX86_microsoft-windows-t..vices-userextension_31bf3856ad364e35_6.1.7600.20661_none_f33c56d65dcb06d6.manifest
File versionNot applicable
File size12,876
Date (UTC)06-Mar-2010
Time (UTC)10:23
PlatformNot applicable

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Keywords: KB980909, kbfix, kbexpertiseadvanced, kbqfe, kbsurveynew, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 980909
Revision : 4
Created on : 4/30/2010
Published on : 4/30/2010
Exists online : False
Views : 354