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Windows Server 2003 SP2 stops responding after a hard link is deleted on a NTFS volume


View products that this article applies to.

Symptoms

You have a computer that is running Windows Server 2003 Service Pack 2 (SP2). When you run an application that deletes a hard link on a NTFS volume, the computer stops responding.

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Cause

This issue occurs because of a deadlock that is caused by the NTFS file system driver (Ntfs.sys).

When an application deletes a hard link, the NTFS file system driver releases some mapped pages incorrectly. This behavior causes the thread that owns a Volume Control Block (VCB) lock to be blocked indefinitely. Additionally, all other threads that require the lock are also blocked. Because this lock is widely used in NTFS operations, many operations are suspended.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.4674593,40803-Mar-201004:53x86
For all supported x64-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.4674593,40803-Mar-201004:53x86
For all supported IA-64-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.4674593,40803-Mar-201004:53x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
For more information, visit the following Microsoft Developer Network (MSDN) Web site:

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Keywords: kbautohotfix, kbhotfixserver, kbfix, kbsurveynew, kbqfe, kbexpertiseadvanced, KB980361

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Article Info
Article ID : 980361
Revision : 1
Created on : 4/14/2010
Published on : 4/14/2010
Exists online : False
Views : 230