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The Print Spooler service crashes when you try to remove a printer on a computer that is running Windows Server 2003 SP2


View products that this article applies to.

Symptoms

When you try to remove a printer on a computer that is running Windows Server 2003 SP2, the Print Spooler service crashes. Additionally, the following event is logged in the System log file:


Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7031
User: N/A
Description:
The Print Spooler service terminated unexpectedly. It has done this <number> time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service.

Note <number> is a placeholder for the number of times that this problem has occurred.

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Cause

This problem occurs because the Printer Spooler tries to access the printer configuration data by enumerating the printer registry. When you try to remove the printer, the enumeration fails and returns an error. However, the Printer Spooler ignores the error and assumes that the enumeration is successful. Therefore, the Printer Spooler crashes when it accesses the printer configuration data.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2). For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The globle version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
For all supported x86-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4677345,60009-Mar-201005:59x86
For all supported x64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4677755,20008-Mar-201014:14x64
For all supported IA-64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4677976,89608-Mar-201014:12IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

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Keywords: kbfix, kbexpertiseinter, kbqfe, kbhotfixserver, kbautohotfix, kbsurveynew, KB980276

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Article Info
Article ID : 980276
Revision : 1
Created on : 4/29/2010
Published on : 4/29/2010
Exists online : False
Views : 288