Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A VDS application cannot enumerate FC HBA ports in the presence of SAS HBA ports in Windows Server 2008 R2 and in Windows 7


View products that this article applies to.

Symptoms

You install a fiber channel (FC) adapter and a serial attached SCSI (SAS) adapter on a computer that is running Windows Server 2008 R2 or Windows 7. When you use the diskraid command or another Virtual Disk Service (VDS) application to enumerate the FC adapter host bus adapter (HBA) ports in the presence of the SAS adapter HBA ports, the list of the HBA ports contains only the SAS adapter HBA ports. If the SAS adapter HBA ports are disabled, the FC adapter HBA ports appear in the list.

↑ Back to the top


Cause

This issue occurs because a flag is not reset. This flag is set when an SAS adapter HBA port cannot be enumerated. Therefore, the FC adapter HBA ports cannot be enumerated even when the FC adapter HBA ports are enabled.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows 7 or Windows Server 2008 R2.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Vds.exe6.1.7600.20661453,12006-Mar-201009:45x86
Vdsldr.exe6.1.7600.1638519,96814-Jul-200901:14x86
Vdsutil.dll6.1.7600.16385151,04014-Jul-200901:16x86
Vds_ps.dll6.1.7600.1638544,54414-Jul-200901:16x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Vds.exe6.1.7600.20661532,99208-Mar-201001:37x64
Vdsldr.exe6.1.7600.1638522,52814-Jul-200901:39x64
Vdsutil.dll6.1.7600.16385185,85614-Jul-200901:41x64
Vds_ps.dll6.1.7600.16385116,73614-Jul-200901:41x64
Vds_ps.dll6.1.7600.2066144,54406-Mar-201009:46x86
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Vds.exe6.1.7600.20661992,25606-Mar-201008:04IA-64
Vdsldr.exe6.1.7600.1638549,15214-Jul-200901:45IA-64
Vdsutil.dll6.1.7600.16385383,48814-Jul-200901:49IA-64
Vds_ps.dll6.1.7600.16385129,02414-Jul-200901:49IA-64
Vds_ps.dll6.1.7600.2066144,54406-Mar-201009:46x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Package_for_kb979940_rtm~31bf3856ad364e35~x86~~6.1.1.0.mumNot Applicable1,94708-Mar-201023:12Not Applicable
X86_microsoft-windows-virtualdiskservice_31bf3856ad364e35_6.1.7600.20661_none_6b5c680a75132e84.manifestNot Applicable64,58808-Mar-201023:15Not Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-virtualdiskservice_31bf3856ad364e35_6.1.7600.20661_none_c77b038e2d709fba.manifestNot Applicable64,59608-Mar-201023:20Not Applicable
Package_for_kb979940_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNot Applicable2,87908-Mar-201023:12Not Applicable
Wow64_microsoft-windows-virtualdiskservice_31bf3856ad364e35_6.1.7600.20661_none_d1cfade061d161b5.manifestNot Applicable53,36306-Mar-201010:10Not Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-virtualdiskservice_31bf3856ad364e35_6.1.7600.20661_none_6b5e0c0075113780.manifestNot Applicable64,59208-Mar-201023:12Not Applicable
Package_for_kb979940_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mumNot Applicable1,95808-Mar-201023:12Not Applicable
Wow64_microsoft-windows-virtualdiskservice_31bf3856ad364e35_6.1.7600.20661_none_d1cfade061d161b5.manifestNot Applicable53,36306-Mar-201010:10Not Applicable

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbsurveynew, kbautohotfix, kbexpertiseinter, kbexpertisebeginner, kbexpertiseadvanced, kbbug, kbfix, KB979940

↑ Back to the top

Article Info
Article ID : 979940
Revision : 1
Created on : 4/14/2010
Published on : 4/14/2010
Exists online : False
Views : 460