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You cannot log off the session for an iSCSI disk or take a disk offline from the Cluster Shared Volumes list in Windows Server 2008 R2 if the disk is an iSCSI disk or a fibre channel disk


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You enable the Cluster Shared Volumes feature on a cluster node that is running Windows Server 2008 R2.
  • You add an iSCSI disk or a fibre channel (FC) disk to the Cluster Shared Volumes list.
  • You set the disk to enter the volume maintenance mode and then set it to exit the volume maintenance mode.
In this scenario,you encounter one or more of the following problems:
  • If the disk is an FC disk, you cannot take this disk offline.
  • If the disk is an iSCSI disk, you cannot log off the session for this disk or take this disk offline.
    Additionally, you receive the following error message:  
    The session cannot be logged out since a device on that session is currently being used.
     
    Also, the following event is added to the System log if the disk is an iSCSI disk: 

     

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Cause

This issue occurs because the Cluster service does not free up some device handles.

When a disk is added to the Cluster Shared Volumes list, the Cluster service opens a handle to the disk device and then assigns an 8-byte persistent reservation key to each cluster node. However, the Cluster service does not free the device handles. Therefore, you encounter this issue.

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Resolution

To resolve this issue, install hotfix 979710 on the affected nodes that are running Windows Server 2008 R2.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.1.7600.207151,240,06419-May-201014:39x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.1.7600.207152,064,89619-May-201014:27IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about how to deploy Cluster Shared Volumes for high-availability clustering in Windows Server 2008 R2, visit the following Microsoft website:

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.1.7600.20715_none_1da4e2c3cf912357.manifestNot Applicable2,69319-May-201016:17Not Applicable
Package_1_for_kb979710~31bf3856ad364e35~amd64~~6.1.1.0.mumNot Applicable2,04820-May-201000:51Not Applicable
Package_for_kb979710_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNot Applicable1,67020-May-201000:51Not Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.1.7600.20715_none_c187eb361731bb1d.manifestNot Applicable2,69119-May-201016:16Not Applicable
Package_1_for_kb979710~31bf3856ad364e35~ia64~~6.1.1.0.mumNot Applicable1,83320-May-201000:51Not Applicable
Package_for_kb979710_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mumNot Applicable1,45620-May-201000:51Not Applicable

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Keywords: kbfix, kbbug, kbexpertiseinter, kbautohotfix, kbqfe, kbhotfixserver, kb, kbclustering, kbsurveynew

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Article Info
Article ID : 979710
Revision : 2
Created on : 9/20/2018
Published on : 9/20/2018
Exists online : False
Views : 320