Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Users cannot view or print End-User-Defined Characters (EUDC) on a computer that is running Windows Server 2008 R2


View products that this article applies to.

Symptoms

You install some End-user-Defined Characters (EUDC) font files on a computer that is running Windows Server 2008 R2 without the "Desktop Experience" feature. However, you cannot view or print these EUDC characters. Additionally, if�the "Remote Desktop Services" role is installed on the computer, users�who are using �Remote Desktop Service� cannot view or print these EUDC characters in their Remote Desktop connections.

↑ Back to the top


Cause

This problem occurs because the EUDC-related registry subkeys do not exist in Windows Server 2008 R2. These subkeys are necessary to view or to print the EUDC characters. These subkeys are located under the HKEY_CURRENT_USER (HKCU)�registry key.�

Note�A user�who has Administrator-level rights can view or print these EUDC characters after running Private Character Editor (Eudcedit.exe). The EUDC-related registry subkey is added automatically by running Eudcedit.exe.

Private Character Editor (Eudcedit.exe) is included in the "Desktop Experience" feature. �Eudcedit.exe requires administrative permissions to be run. Therefore, non-admin users cannot even run the tool to enable EUDC characters.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2008 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are very important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Eudcsettings.exe6.1.7600.2062514,33623-Jan-201008:07x64
Eudcedit.exe6.1.7600.20625359,93623-Jan-201008:07x64
Eudcedit.exe6.1.7600.20625288,25623-Jan-201007:35x86
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Eudcsettings.exe6.1.7600.2062524,57623-Jan-201006:43IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about EUDC, visit the following Web site:For more information about End-User-Defined and Private Use Area Characters, visit the following Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_7f23a689e1103fe7a5e9e2ed6e6064b5_31bf3856ad364e35_6.1.7600.20625_none_6a0e7a7aad2c5000.manifest
File versionNot Applicable
File size705
Date (UTC)25-Jan-2010
Time (UTC)21:14
PlatformNot Applicable
File nameAmd64_9d8ba7e1dc8b886ad81e21708041ce3b_31bf3856ad364e35_6.1.7600.20625_none_9589a8817ee4f597.manifest
File versionNot Applicable
File size700
Date (UTC)25-Jan-2010
Time (UTC)21:14
PlatformNot Applicable
File nameAmd64_c7f71d1e943e00eddecfbfbc5d3b46a2_31bf3856ad364e35_6.1.7600.20625_none_cb4fa031b2c96cde.manifest
File versionNot Applicable
File size698
Date (UTC)25-Jan-2010
Time (UTC)21:14
PlatformNot Applicable
File nameAmd64_microsoft-windows-eudc-settings_31bf3856ad364e35_6.1.7600.20625_none_b6e735900ad5f41e.manifest
File versionNot Applicable
File size3,239
Date (UTC)23-Jan-2010
Time (UTC)08:35
PlatformNot Applicable
File nameAmd64_microsoft-windows-eudcedit_31bf3856ad364e35_6.1.7600.20625_none_b657f66bf21c2052.manifest
File versionNot Applicable
File size5,032
Date (UTC)23-Jan-2010
Time (UTC)08:43
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,877
Date (UTC)25-Jan-2010
Time (UTC)21:14
PlatformNot Applicable
File nameX86_microsoft-windows-eudcedit_31bf3856ad364e35_6.1.7600.20625_none_5a395ae839beaf1c.manifest
File versionNot Applicable
File size5,028
Date (UTC)23-Jan-2010
Time (UTC)08:01
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_ab4c31db9a52546191fcf5ac1ee3dd66_31bf3856ad364e35_6.1.7600.20625_none_c95e27642d7f0c4d.manifest
File versionNot Applicable
File size703
Date (UTC)25-Jan-2010
Time (UTC)21:14
PlatformNot Applicable
File nameIa64_microsoft-windows-eudc-settings_31bf3856ad364e35_6.1.7600.20625_none_5aca3e0252768be4.manifest
File versionNot Applicable
File size3,238
Date (UTC)23-Jan-2010
Time (UTC)08:30
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,463
Date (UTC)25-Jan-2010
Time (UTC)21:14
PlatformNot Applicable

↑ Back to the top


Keywords: KB979580, kbfix, kbqfe, kbautohotfix, kbHotfixServer, kbexpertiseadvanced, kbsurveynew, kbprb

↑ Back to the top

Article Info
Article ID : 979580
Revision : 2
Created on : 6/10/2010
Published on : 6/10/2010
Exists online : False
Views : 276