Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The creator of an SNMP trap notification cannot be identified in Windows Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You enable the Simple Network Management Protocol (SNMP) feature for the Windows Management Instrumentation (WMI) provider on a computer that is running Windows Server 2003 in a Network Address Translation (NAT) environment.
  • The computer creates an SNMP trap notification, and then it sends the notification through a NAT router.
  • The SNMP trap notification is received by a server.
In this scenario, both the AgentAddress property and the AgentTransportAddress property are set to the IP address of the NAT router in the SnmpNotification class of the notification. Therefore, the computer that created the SNMP trap notification cannot be identified.

Note The AgentAddress property is the network address of the entity that created the notification. The AgentTransportAddress property is the network address of the entity that sent the notification.

↑ Back to the top


Cause

This issue occurs because of an error in the SNMP WMI provider. The SNMP WMI provider incorrectly set the AgentAddress property of the SNMP trap notification.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes

For all supported x86-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Snmpincl.dll5.2.3790.4651360,44819-Jan-201002:55x86
For all supported x64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Snmpincl.dll5.2.3790.4651623,61620-Jan-201002:02x64
For all supported IA-64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Snmpincl.dll5.2.3790.46511,145,85620-Jan-201002:02IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the SNMP WMI provider, visit the following Microsoft Web site: For more information about the SnmpNotification class, visit the following Microsoft Developer Network (MSDN) Web site: For more information about how to set up the WMI SNMP environment, visit the following MSDN Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbexpertiseadvanced, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbautohotfix, KB979554

↑ Back to the top

Article Info
Article ID : 979554
Revision : 1
Created on : 2/12/2010
Published on : 2/12/2010
Exists online : False
Views : 262