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The CPU usage for the Dfrgntfs.exe process increases to 100 percent and stays at that level in Windows Server 2003


View products that this article applies to.

Symptoms

You run the NTFS Module of the Disk Defragmenter tool (Dfrgntfs.exe) to defragment a hard disk on a computer that is running Windows Server 2003. The defragmenting process does not finish successfully. In Task Manager, you notice that the CPU usage for the Dfrgntfs.exe process increases to 100 percent and stays at that level.

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Cause

The issue occurs because the Defrgntfs.exe process enters an infinite loop.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information note
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Dfrgntfs.exe5.2.3790.4709542,59214-May-2010:47x86
For all supported x64-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Dfrgntfs.exe5.2.3790.4709166,40013-May-20101:31x64
For all supported IA-64-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Dfrgntfs.exe5.2.3790.4709332,28813-May-20101:34IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbexpertiseinter, kbfix, kbhotfixserver, kbqfe, kbautohotfix, kbsurveynew, kbprb, KB979550

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Article Info
Article ID : 979550
Revision : 4
Created on : 11/1/2010
Published on : 11/1/2010
Exists online : False
Views : 305