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You cannot enter an agreement number of a volume license that contains more than seven digits in Remote Desktop Licensing Manager or in TS Licensing Manager


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You start TS Licensing Manager (Licmgr.exe) on a computer that is running Windows Server 2008. Or, you start Remote Desktop License Manager (Licmgr.exe) on a computer that is running Windows Server 2008 R2.
  • You try to install a volume license for one of the following licenses:
    • Select License
    • Enterprise Agreement
    • Campus Agreement
    • School Agreement
    • Service Provider License Agreement
    • Other Agreement
In this scenario, you cannot enter an agreement number that is more than seven digits.

Note The issue also occurs if you install terminal licenses by the commands that are provided by Windows Management Instrument (WMI) or by Windows PowerShell.

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Cause

This issue occurs because Remote Desktop Licensing Manager, Terminal Services Licensing Manager, WMI, and Windows PowerShell incorrectly restrict the agreement numbers for volume licenses to only seven digits.

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Resolution

This hotfix also removes the check on authorization numbers and license numbers for open licenses.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 or Windows Server 2008 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    1.
    22xxx
    Windows Server 2008SP1LDR
    6.0.600
    2.
    22xxx
    Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Licmgr.exe6.0.6001.22608357,88819-Jan-201019:57x86
Lrwizdll.dll6.0.6001.22608509,44019-Jan-201022:01x86
Licmgr.exe6.0.6002.22314357,88819-Jan-201019:51x86
Lrwizdll.dll6.0.6002.22314509,44019-Jan-201021:59x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Licmgr.exe6.0.6001.22608405,50419-Jan-201020:23x64
Lrwizdll.dll6.0.6001.22608577,53619-Jan-201022:24x64
Licmgr.exe6.0.6002.22314405,50419-Jan-201020:15x64
Lrwizdll.dll6.0.6002.22314577,53619-Jan-201022:03x64
Windows Server 2008 R2 file information note
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Licmgr.exe6.1.7600.16385410,62414-Jul-200901:39x64
Lrwizdll.dll6.1.7600.20621585,72819-Jan-201010:28x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Licmgr.exe.mui6.1.7600.1638566,56014-Jul-200902:26Not applicable
Lrwizdll.dll.mui6.1.7600.20621150,52819-Jan-201008:54Not applicable
Licmgr.exe.mui6.1.7600.1638556,32014-Jul-200901:38Not applicable
Lrwizdll.dll.mui6.1.7600.20621134,65619-Jan-201008:53Not applicable
Licmgr.exe.mui6.1.7600.1638572,19214-Jul-200902:25Not applicable
Lrwizdll.dll.mui6.1.7600.20621162,30419-Jan-201008:46Not applicable
Licmgr.exe.mui6.1.7600.1638540,44814-Jul-200904:37Not applicable
Lrwizdll.dll.mui6.1.7600.2062197,28019-Jan-201009:28Not applicable
Licmgr.exe.mui6.1.7600.1638537,88814-Jul-200904:36Not applicable
Lrwizdll.dll.mui6.1.7600.2062190,11219-Jan-201009:28Not applicable
Licmgr.exe.mui6.1.7600.1638529,69614-Jul-200904:12Not applicable
Lrwizdll.dll.mui6.1.7600.2062174,24019-Jan-201009:21Not applicable
Licmgr.exe.mui6.1.7600.1638530,72014-Jul-200904:35Not applicable
Lrwizdll.dll.mui6.1.7600.2062175,77619-Jan-201009:28Not applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kb, kbexpertiseadvanced, kbhotfixserver, kbfix, kbqfe, kbautohotfix, kbsurveynew, kbprb

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Article Info
Article ID : 979548
Revision : 5
Created on : 9/20/2018
Published on : 9/20/2018
Exists online : False
Views : 400