Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A Windows Server 2008 R2-based Remote Desktop server denies some connection requests randomly under heavy logon or logoff conditions


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a Windows Server 2008 R2-based computer that has the Remote Desktop Service role installed.
  • Many users try to log on to or log off from the Remote Desktop server at the same time.

    Note this issue may occur when seven to ten users try to log on or log off at the same time.
In this scenario, the Remote Desktop server denies some connection requests. Additionally, you receive the following error message:

The remote procedure call failed and did not execute.


Note If a user tries to connect again, the user may be succeed at the second try.

↑ Back to the top


Cause

This issue is caused by a race condition in the remote procedure call (RPC) module.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2008 R2 with the Remote Desktop Service role installed.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you install this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are very important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Regapi.dll6.1.7600.2062195,23219-Jan-201010:30x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Regapi.dll6.1.7600.20621183,29619-Jan-201009:01IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

970689 A Windows Server 2008-based terminal server denies connection requests with the error message "The remote procedure call failed and did not execute" randomly under a heavy logon/logoff condition

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_461dd0607814fc992a4dbb8700d4d4f6_31bf3856ad364e35_6.1.7600.20621_none_291109329cf552b2.manifest
File versionNot Applicable
File size721
Date (UTC)20-Jan-2010
Time (UTC)00:43
PlatformNot Applicable
File nameAmd64_f02270b20fa9c8441f320f77f97e60b6_31bf3856ad364e35_6.1.7600.20621_none_a3ebe8236e0f58a5.manifest
File versionNot Applicable
File size719
Date (UTC)20-Jan-2010
Time (UTC)00:43
PlatformNot Applicable
File nameAmd64_microsoft-windows-t..rvices-registryapis_31bf3856ad364e35_6.1.7600.20621_none_010d9870549d4110.manifest
File versionNot Applicable
File size2,431
Date (UTC)19-Jan-2010
Time (UTC)13:39
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,328
Date (UTC)20-Jan-2010
Time (UTC)00:43
PlatformNot Applicable
File nameX86_microsoft-windows-t..rvices-registryapis_31bf3856ad364e35_6.1.7600.20621_none_a4eefcec9c3fcfda.manifest
File versionNot Applicable
File size2,429
Date (UTC)19-Jan-2010
Time (UTC)13:40
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_efeabf0bb7474f83f63a296d8165af2b_31bf3856ad364e35_6.1.7600.20621_none_c53ae327dc6b6120.manifest
File versionNot Applicable
File size719
Date (UTC)20-Jan-2010
Time (UTC)00:43
PlatformNot Applicable
File nameIa64_f02270b20fa9c8441f320f77f97e60b6_31bf3856ad364e35_6.1.7600.20621_none_47cef095b5aff06b.manifest
File versionNot Applicable
File size718
Date (UTC)20-Jan-2010
Time (UTC)00:43
PlatformNot Applicable
File nameIa64_microsoft-windows-t..rvices-registryapis_31bf3856ad364e35_6.1.7600.20621_none_a4f0a0e29c3dd8d6.manifest
File versionNot Applicable
File size2,430
Date (UTC)19-Jan-2010
Time (UTC)13:40
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,684
Date (UTC)20-Jan-2010
Time (UTC)00:43
PlatformNot Applicable
File nameX86_microsoft-windows-t..rvices-registryapis_31bf3856ad364e35_6.1.7600.20621_none_a4eefcec9c3fcfda.manifest
File versionNot Applicable
File size2,429
Date (UTC)19-Jan-2010
Time (UTC)13:40
PlatformNot Applicable

↑ Back to the top


Keywords: kb, kbprb, kbsurveynew, kbexpertiseadvanced, kbhotfixserver, kbautohotfix, kbqfe, kbfix

↑ Back to the top

Article Info
Article ID : 979530
Revision : 1
Created on : 1/7/2017
Published on : 10/10/2011
Exists online : False
Views : 193