Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Eror message on a client computer that is running Windows Vista or Windows Server 2008: "ERROR_NOT_LOCKED (158)"


View products that this article applies to.

Symptoms

Consider the following scenario in a network environment:
  • You set up a file share on a server that is running Windows Vista or Windows Server 2008.
  • You have a client computer (client 1) that is running Windows Vista or Windows Server 2008.
  • You also have another client computer (client 2) that is running a Windows operating system that is earlier than Windows Vista. For example, you have a client computer that is running Windows XP or Windows Server 2003.
  • You run two applications on client 1. At the same time, you run one application on client 2. All the three applications perform file I/O operations to the file share. For example, these applications may lock part of a file on the file share, edit and then unlock the file.
In this scenario, one of the applications on client 1 fails, and all the other applications stop working.

To monitor the file I/O activity of the three applications, you can use Process Monitor. When you experience this issue, you will find that an error that resembles the following is logged for the affected application:
ERROR_NOT_LOCKED (158)
Process Monitor also indicates that the error occurs in the UnlockFile function.

↑ Back to the top


Cause

This issue occurs because of a race condition between two versions of the Server Message Block (SMB) environment. Windows operating systems that are earlier than Windows Vista use SMB1. However, Windows Vista and Windows Server 2008 use SMB2. In a mixed SMB1 and SMB2 environment, when several applications are performing file I/O operations to a file share, the applications may form a "lock-lock-unlock" cycle. In this situation, an "ERROR_NOT_LOCKED" error occurs.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Vista Service Pack 2 or Windows Server 2008 Service Pack 2.

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The Global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Srv2.sys6.0.6002.22313144,89615-Jan-201017:17x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Srv2.sys6.0.6002.22313174,59215-Jan-201017:20x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Srv2.sys6.0.6002.22313465,40815-Jan-201018:03IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the UnlockFile function, visit the following Microsoft Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameX86_cd51dd0886d744211d7d29fbab5bb620_31bf3856ad364e35_6.0.6002.22313_none_70eed6a561ddb2c2.manifest
File versionNot applicable
File size700
Date (UTC)19-Jan-2010
Time (UTC)04:40
PlatformNot applicable
File nameX86_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.0.6002.22313_none_dc54e2920cc5026d.manifest
File versionNot applicable
File size4,426
Date (UTC)16-Jan-2010
Time (UTC)01:16
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_591292df532abe81c71435d5b8e5a134_31bf3856ad364e35_6.0.6002.22313_none_a8e08c61dc893a14.manifest
File versionNot applicable
File size704
Date (UTC)19-Jan-2010
Time (UTC)04:40
PlatformNot applicable
File nameAmd64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.0.6002.22313_none_38737e15c52273a3.manifest
File versionNot applicable
File size4,688
Date (UTC)16-Jan-2010
Time (UTC)01:09
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_e72ba593ebdffc175a34d41ebb09fa49_31bf3856ad364e35_6.0.6002.22313_none_188fcfa26478449c.manifest
File versionNot applicable
File size702
Date (UTC)19-Jan-2010
Time (UTC)04:40
PlatformNot applicable
File nameIa64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.0.6002.22313_none_dc5686880cc30b69.manifest
File versionNot applicable
File size4,683
Date (UTC)16-Jan-2010
Time (UTC)01:01
PlatformNot applicable

↑ Back to the top


Keywords: kbfix, kbhotfixserver, kbqfe, kbautohotfix, kbsurveynew, kbprb, KB979521

↑ Back to the top

Article Info
Article ID : 979521
Revision : 1
Created on : 2/8/2010
Published on : 2/8/2010
Exists online : False
Views : 280