Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Users do not receive new messages if they use IMAP4 clients to access mailboxes that were moved to another Exchange Server 2010 RU1 server


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Update Rollup 1 for Microsoft Exchange Server 2010 on computers that are running Exchange Server 2010.
  • You move mailboxes from one server to another server within the same database availability group.
  • Users use IMAP4 clients to access the mailboxes.
In this scenario, the users can view the old messages that were received before their mailboxes were moved. However, the users cannot view new messages.

Note This problem does not occur when users access the mailboxes that were moved by using Microsoft Office Outlook in MAPI mode or by using Microsoft Office Outlook Web Access (OWA).

↑ Back to the top


Cause

This problem occurs because the Unique Identifier attributes of the messages change when the mailboxes are moved. However, the UIDNEXT attributes of the folders do not change when the mailboxes are moved. When IMAP4 clients try to synchronize the new messages, the UIDNEXT attribute should be referenced. However, no messages match the UIDNEXT attribute. This behavior occurs because the sequence of Unique Identifier attributes of the messages already changed.

↑ Back to the top


Resolution

To fix this problem, install the following update rollup:
979611 Description of Update Rollup 2 for Exchange Server 2010: February 18, 2010

NoteOnce a mailbox has been moved to an Exchange Server 2010 server before the hotfix is installed, the Unique Identifier (UID) attributes on the messages is broken because the hotfix keeps the old UID attributes during the mailbox moving process. To fix the problem on the affected mailbox, you can use an Outlook client to move all the messages from the Inbox folder to a new mail folder and then move them back to the Inbox folder. This behavior will rewrite the UID attributes correctly and the new messages should start to work.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information



For more information about the Unique Identifier attribute and UIDNEXT attribute, visit the following IETF Web site:

↑ Back to the top


Keywords: KB979480, kbqfe, kbfix, kbhotfixrollup, kbsurveynew, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 979480
Revision : 3
Created on : 3/4/2010
Published on : 3/4/2010
Exists online : False
Views : 458