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You cannot start a second application from an application by using the CreateProcess function in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You develop an application (application A) that calls the CreateProcess function to start another application (application B).
  • In application A, you set the dwFlags field as STARTF_TITLEISAPPID to specify an AppID key for application B.
  • You try to run application A on a computer that is running Windows 7 or Windows Server 2008 R2.
In this scenario, you cannot start application B from application A.

Note This issue occurs when application B calls the SetCurrentProcessExplicitAppUserModelID function to specify the AppID key. For example, the following applications call the SetCurrentProcessExplicitAppUserModelID function to specify the AppID key:
  • Windows Internet Explorer (Iexplorer.exe)
  • Windows Media Player (Wmplayer.exe)
  • Remote Desktop Connection (Mstsc.exe)

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Cause

This issue occurs because of a heap corruption. This heap corruption occurs when the SetCurrentProcessExplicitAppUserModelID function tries to handle an AppID that is previously set by the CreateProcess function.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Shell32.dll6.1.7600.2063512,867,07204-Feb-201007:02x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Shell32.dll6.1.7600.2063514,162,94404-Feb-201007:54x64
Shell32.dll6.1.7600.2063512,867,07204-Feb-201007:02x86
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Shell32.dll6.1.7600.2063521,168,64004-Feb-201006:20IA-64
Shell32.dll6.1.7600.2063512,867,07204-Feb-201007:02x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, visit the following Microsoft Web sites: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameX86_184737d7ce16a2e453350a71aadf2dc0_31bf3856ad364e35_6.1.7600.20635_none_538c7f800b828dd5.manifest
File versionNot applicable
File size695
Date (UTC)04-Feb-2010
Time (UTC)10:37
PlatformNot applicable
File nameX86_microsoft-windows-shell32_31bf3856ad364e35_6.1.7600.20635_none_6cbf31348c449193.manifest
File versionNot applicable
File size1,059,457
Date (UTC)04-Feb-2010
Time (UTC)07:22
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_277519f3d27643ecfad64d9b9d2da6e5_31bf3856ad364e35_6.1.7600.20635_none_90d6346d18b0ca7b.manifest
File versionNot applicable
File size699
Date (UTC)04-Feb-2010
Time (UTC)10:37
PlatformNot applicable
File nameAmd64_b01f65dacffff6172e3b87538d98074a_31bf3856ad364e35_6.1.7600.20635_none_9370934a5740be05.manifest
File versionNot applicable
File size1,040
Date (UTC)04-Feb-2010
Time (UTC)10:37
PlatformNot applicable
File nameAmd64_microsoft-windows-shell32_31bf3856ad364e35_6.1.7600.20635_none_c8ddccb844a202c9.manifest
File versionNot applicable
File size1,058,443
Date (UTC)04-Feb-2010
Time (UTC)08:23
PlatformNot applicable
File nameWow64_microsoft-windows-shell32_31bf3856ad364e35_6.1.7600.20635_none_d332770a7902c4c4.manifest
File versionNot applicable
File size1,054,916
Date (UTC)04-Feb-2010
Time (UTC)07:16
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_218d929d0c70e030ad5cd572be29a01d_31bf3856ad364e35_6.1.7600.20635_none_f10c98b84b010f93.manifest
File versionNot applicable
File size1,038
Date (UTC)04-Feb-2010
Time (UTC)10:37
PlatformNot applicable
File nameIa64_microsoft-windows-shell32_31bf3856ad364e35_6.1.7600.20635_none_6cc0d52a8c429a8f.manifest
File versionNot applicable
File size1,058,441
Date (UTC)04-Feb-2010
Time (UTC)07:50
PlatformNot applicable
File nameWow64_microsoft-windows-shell32_31bf3856ad364e35_6.1.7600.20635_none_d332770a7902c4c4.manifest
File versionNot applicable
File size1,054,916
Date (UTC)04-Feb-2010
Time (UTC)07:16
PlatformNot applicable

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Keywords: kbexpertiseadvanced, kbfix, kbhotfixserver, kbautohotfix, kbsurveynew, kbprb, KB979275

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Article Info
Article ID : 979275
Revision : 1
Created on : 4/14/2010
Published on : 4/14/2010
Exists online : False
Views : 493