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Error message when you try to add a user account to a role or delete a user account from a role: "Cannot save one or more changes. The following problem occurred: The parameter is incorrect"


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Authorization Manager on a computer that is running Windows Server 2008. This computer joins a domain.
  • You create an authorization store by using the Active Directory or Active Directory Application Mode (ADAM) store type.
  • You try to add a user account to a role in this authorization store or delete a user account from a role in this authorization store. The user account is from another domain. A trust relationship exists between the two domains.
In this scenario, you cannot add this user account to the role or delete this user account from the role. Additionally, you receive an error message that resembles the following:
Cannot save one or more changes. The following problem occurred: The parameter is incorrect.

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Cause

This issue occurs because Authorization Manager cannot add a user account that is located in another domain to a role. Also, Authorization Manager cannot delete a user account that is located in another domain from a role.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2008 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849� How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.600 2 . 22xxxWindows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Azroles.dll6.0.6002.22311757,76013-Jan-201017:48x86
Azsqlext.dll6.0.6002.2231128,16013-Jan-201017:48x86
For all supported x64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Azroles.dll6.0.6002.22311896,00013-Jan-201017:50x64
Azsqlext.dll6.0.6002.2231131,74413-Jan-201017:50x64
For all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Azroles.dll6.0.6002.223111,539,58413-Jan-201017:39IA-64
Azsqlext.dll6.0.6002.2231172,19213-Jan-201017:39IA-64

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Workaround

Workaround for Windows Server 2008

To work around this issue, follow these steps:
  1. Create a local group in the domain where the Authorization Manager store resides.
  2. Add the user account from another domain to the local group.
  3. Assign the role to the local group.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about Authorization Manager, visit the following Microsoft Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
Collapse this tableExpand this table
File namePUpdate.mum
File versionNot applicable
File size3,068
Date (UTC)15-Jan-2010
Time (UTC)11:57
PlatformNot applicable
File nameX86_f7ba2e985a7d9a4373838509de9ab9da_31bf3856ad364e35_6.0.6002.22311_none_483d6cfa066a4cfe.manifest
File versionNot applicable
File size693
Date (UTC)15-Jan-2010
Time (UTC)11:57
PlatformNot applicable
File nameX86_microsoft-windows-azman_31bf3856ad364e35_6.0.6002.22311_none_58bd61c4c9047892.manifest
File versionNot applicable
File size104,594
Date (UTC)13-Jan-2010
Time (UTC)22:42
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameAmd64_3500cc47f416fed14667b30826c168d1_31bf3856ad364e35_6.0.6002.22311_none_677fdcde3f0a9077.manifest
File versionNot applicable
File size1,034
Date (UTC)15-Jan-2010
Time (UTC)11:57
PlatformNot applicable
File nameAmd64_microsoft-windows-azman_31bf3856ad364e35_6.0.6002.22311_none_b4dbfd488161e9c8.manifest
File versionNot applicable
File size104,638
Date (UTC)13-Jan-2010
Time (UTC)22:40
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,092
Date (UTC)15-Jan-2010
Time (UTC)11:57
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameIa64_662f4da1214ecbcf681478349327f121_31bf3856ad364e35_6.0.6002.22311_none_38984c418326e06e.manifest
File versionNot applicable
File size1,032
Date (UTC)15-Jan-2010
Time (UTC)11:57
PlatformNot applicable
File nameIa64_microsoft-windows-azman_31bf3856ad364e35_6.0.6002.22311_none_58bf05bac902818e.manifest
File versionNot applicable
File size104,616
Date (UTC)13-Jan-2010
Time (UTC)22:07
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,247
Date (UTC)15-Jan-2010
Time (UTC)11:57
PlatformNot applicable

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Keywords: kbexpertiseinter, kbfix, kbhotfixserver, kbqfe, kbautohotfix, kbsurveynew, kbprb, KB979100

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Article Info
Article ID : 979100
Revision : 1
Created on : 2/9/2010
Published on : 2/9/2010
Exists online : False
Views : 378