Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive error messages that reports are not found when you run reports on the Stockkeeping Unit page in the North America version of Microsoft Dynamics NAV 2009 SP1


View products that this article applies to.

Rapidly Published articles provide information directly from within the Microsoft support organization. The information that is contained herein is created in response to emerging or unique topics, or is intended to supplement other Knowledge Base information.

↑ Back to the top


This article applies to Microsoft Dynamics NAV for the following countries and language locales.
  • English (Canada) (en-ca)
  • English (United States) (en-us)
  • Spanish (Mexico) (es-mx)
  • French (Canada) (fr-ca)

↑ Back to the top


Symptoms

When you try to run reports on the Stockkeeping Unit page in the North America version of Microsoft Dynamics NAV 2009 with Service Pack 1 (SP1), you receive error messages that these reports are not found. The actual error message is as follows:
Metadata for object of type Report with id ID is in a failed state. This is caused by a previous exception:
Object of type Report with id 701 could not be found.

In this error message, ID represents an actual report ID.

↑ Back to the top


Cause

This problem occurs because these reports are not in the North America database.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is only intended to correct the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics NAV service pack or the next version that contains this hotfix.

Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


↑ Back to the top




Installation information

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.

Note Before you install this hotfix, verify that all Microsoft Navision client users are logged off the system. This includes Microsoft Navision Application Services (NAS) client users. You should be the only client user who is logged on when you implement this hotfix.

To implement this hotfix, you must have a developer license.

We recommend that the user account in the Windows Logins window or in the Database Logins window be assigned the "SUPER" role ID. If the user account cannot be assigned the "SUPER" role ID, you must verify that the user account has the following permissions:
  • The Modify permission for the object that you will be changing.
  • The Execute permission for the System Object ID 5210 object and for the System Object ID 9015 object.


Note You do not have to have rights to the data stores unless you have to perform data repair.

Code changes

Note Always test code fixes in a controlled environment before you apply the fixes to your production computers.

To install this hotfix, change the code in the "Stockkeeping Unit List" page (5701).

To do this, follow these steps:
  1. On the View menu, click Actions.
  2. Modify the Runobject property of actions as follows.
    Existing code
      { 1900907306;1 ;Action    ;
    CaptionML=[ENU=Inventory - List;
    ESM=Existencias - Listado;
    FRC=Inventaire - Liste;
    ENC=Inventory - List];

    RunObject=Report 701; // Delete this line.

    Promoted=Yes;
    PromotedCategory=Report }
    { 1901091106;1 ;Action ;
    CaptionML=[ENU=Inventory Availability;
    ESM=Disponibilidad existencias;
    FRC=Disponibilit‚ de l'inventaire;
    ENC=Inventory Availability];

    RunObject=Report 705; // Delete this line.

    Promoted=Yes;
    PromotedCategory=Report }
    { 1906212206;1 ;Action ;
    CaptionML=[ENU=Inventory - Availability Plan;
    ESM=Existencias - Proyecci¢n existencias;
    FRC=Inventaire - Plan de disponibilit‚;
    ENC=Inventory - Availability Plan];
    RunObject=Report 707;
    Promoted=Yes;
    PromotedCategory=Report }
    { 1900430206;1 ;Action ;
    CaptionML=[ENU=Item/Vendor Catalog;
    ESM=Producto - Lista proveedores;
    FRC=Catalogue article/fournisseur;
    ENC=Item/Vendor Catalogue];

    RunObject=Report 720; // Delete this line.

    Promoted=Yes;
    PromotedCategory=Report }
    { 1900000004;0 ;ActionContainer;



    Replacement code
    { 1900907306;1 ;Action    ;
    CaptionML=[ENU=Inventory - List;
    ESM=Existencias - Listado;
    FRC=Inventaire - Liste;
    ENC=Inventory - List];

    RunObject=Report 10143; // Add this line.

    Promoted=Yes;
    PromotedCategory=Report }
    { 1901091106;1 ;Action ;
    CaptionML=[ENU=Inventory Availability;
    ESM=Disponibilidad existencias;
    FRC=Disponibilit‚ de l'inventaire;
    ENC=Inventory Availability];

    RunObject=Report 10131; // Add this line.

    Promoted=Yes;
    PromotedCategory=Report }
    { 1906212206;1 ;Action ;
    CaptionML=[ENU=Inventory - Availability Plan;
    ESM=Existencias - Proyecci¢n existencias;
    FRC=Inventaire - Plan de disponibilit‚;
    ENC=Inventory - Availability Plan];
    RunObject=Report 707;
    Promoted=Yes;
    PromotedCategory=Report }
    { 1900430206;1 ;Action ;
    CaptionML=[ENU=Item/Vendor Catalog;
    ESM=Producto - Lista proveedores;
    FRC=Catalogue article/fournisseur;
    ENC=Item/Vendor Catalogue];

    RunObject=Report 10164; // Add this line.

    Promoted=Yes;
    PromotedCategory=Report }
    { 1900000004;0 ;ActionContainer;

  3. Save the changes that you made.

Prerequisites

You must have the North America version of Microsoft Dynamics NAV 2009 Service Pack 1 installed to apply this hotfix.

Removal information

You cannot remove this hotfix.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


MICROSOFT AND/OR ITS SUPPLIERS MAKE NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY, THE RELIABILITY OR THE ACCURACY OF THE INFORMATION THAT IS CONTAINED IN THE DOCUMENTS AND THE RELATED GRAPHICS PUBLISHED ON THIS WEB SITE (THE “MATERIALS”) FOR ANY PURPOSE.

THE MATERIALS MAY INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS AND MAY BE REVISED AT ANY TIME WITHOUT NOTICE. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT AND/OR ITS SUPPLIERS DISCLAIM AND EXCLUDE ALL REPRESENTATIONS, WARRANTIES, AND CONDITIONS WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO REPRESENTATIONS, WARRANTIES, OR CONDITIONS OF TITLE, NON-INFRINGEMENT, SATISFACTORY CONDITION OR QUALITY, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE MATERIALS.

↑ Back to the top


Keywords: kbmbsquickpub, kbnoloc, kbmbscodefix, kbqfe, kbmbsmigrate, kbmbsinventory, kbsurveynew, kbnotautohotfix, kb, kberrmsg, kbmbspartner

↑ Back to the top

Article Info
Article ID : 978923
Revision : 2
Created on : 9/26/2018
Published on : 9/26/2018
Exists online : False
Views : 220