Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Fast inventory fails when you try to use an IBM 35XX Series mainframe with Data Protection Manager


View products that this article applies to.

Symptoms

When you try to perform a fast inventory with the Microsoft System Center Data Protection Manager (DPM), you receive the following error message:
Type: Fast inventory

Status: Failed

Description: DPM failed to inventory the Tape Library IBM 35XX Tape Library. This is possibly due to a hardware issue. (ID 25011 Details: Internal error code: 0x80990C1B)



End time: MM/DD/YYYYh:mm:ssAM_PM
Start time: MM/DD/YYYYh:mm:ssAM_PM
Library: IBM 35XX Tape Library

↑ Back to the top


Cause

This issue occurs when you have tape cleaner media in an IBM 35XX series library, and you use DPM to try to run a fast inventory. When there is tape cleaner media in a slot or drive, and you try to run the fast inventory, this slot or drive returns an unhandled error message. In this scenario, the fast inventory fails.



Note A DPM fast inventory will work as expected when auto cleaning is enabled, and the tape cleaner media is loaded only in special cleaning slots. If the cleaner media is present in a regular slot, the status of the slot is reported as an exception. If the cleaner media is in drive, the status of the drive is also reported as an exception.


Note Similar errors may occur when you try to clean a tape drive by using the DPM GUI, and there is cleaning tape media in the library.

↑ Back to the top


Workaround

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To work around this issue, on the DPM server that contains the tape library, you can add RSMCompatMode as a DWORD Value to the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent
To do this, follow these steps.
 
Note The RSMCompatMode registry value is used to specify multiple flags for DPM. The following are the flags that are set by this registry value:
 
  • 1 = RSM_COMPAT_INIT_ELEMENT_STATUS
  • 4 = RSM_COMPAT_IGNORE_TAPE_INVENTORY_RESULT
  • 8 = RSM_COMPAT_CLEANER_EXCEPTION
  1. Stop the DPM Library Agent (DPMLA) service. To do this, follow these steps:
    1. Click StartStart Button , click All Programs, click Accessories, and then right-click Command Prompt.
    2. Click Run as administrator.

      AUC If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.
    3. At the command prompt, type net stop dpmla, and then press ENTER.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent
  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type RSMCompatMode, and then press ENTER.
  6. On the Edit menu, click Modify.
  7. Type 8 or 13 (decimal), and then click OK.
  8. Exit Registry Editor.
  9. Start the DPMLA service. To do this, follow these steps:
    1. Click StartStart Button , click All Programs, click Accessories, and then right-click Command Prompt.
    2. Click Run as administrator.

      AUC If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.
    3. At the command prompt, type net start dpmla, and then press ENTER.

↑ Back to the top


Keywords: kb, kbprb, kbsurveynew, kbtshoot, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 978901
Revision : 8
Created on : 10/9/2020
Published on : 10/9/2020
Exists online : False
Views : 63