Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message in Windows 7 or in Windows Server 2008 R2: 0x8007007E


View products that this article applies to.

Symptoms

You have a computer that is running a 64-bit edition of Windows 7 or of Windows Server 2008 R2. When you run the W32tm.exe /resync command from the %SystemRoot%\SysWow64 folder in an elevated command prompt, the operation fails. Additionally, you receive an error message that resembles the following:
The specified module could not be found. <0x8007007E>

↑ Back to the top


Cause

This issue occurs because a 32-bit version of the W32time.dll module is missing in a 64-bit edition of Windows 7.

In a 64-bit edition of Windows 7, there are two versions of the W32tm.exe tool:
  • A 64-bit version of the tool is located in %SystemRoot%\System32.
  • A 32-bit version of the tool is located in %SystemRoot%\SysWow64.
If you run the 32-bit version of W32tm.exe together with the /resync option, it loads the W32time.dll module. However, the operating system cannot locate an appropriate version of the W32time.dll module. Therefore, you receive the error message.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
W32tm.exe6.1.7600.2060581,40829-Dec-200907:51x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
W32tm.exe6.1.7600.20605184,32029-Dec-200906:24IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the W32tm.exe tool, click here.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_3b53051e84c026683363c97f70b1f27f_31bf3856ad364e35_6.1.7600.20605_none_a8f64dd478bd368e.manifest
File version
File size699
Date (UTC)30-Dec-2009
Time (UTC)05:49
PlatformNot Applicable
File nameAmd64_b92a37dbc22e03fe8a75a18891fb013c_31bf3856ad364e35_6.1.7600.20605_none_f86d444fcadb3194.manifest
File version
File size701
Date (UTC)30-Dec-2009
Time (UTC)05:49
PlatformNot Applicable
File nameAmd64_microsoft-windows-time-tool_31bf3856ad364e35_6.1.7600.20605_none_49de2cf46e7c3b3d.manifest
File version
File size2,765
Date (UTC)29-Dec-2009
Time (UTC)19:10
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_3b53051e84c026683363c97f70b1f27f_31bf3856ad364e35_6.1.7600.20605_none_4cd95646c05dce54.manifest
File version
File size698
Date (UTC)30-Dec-2009
Time (UTC)05:48
PlatformNot Applicable
File nameIa64_d072423b3a550a57480810563f3c043d_31bf3856ad364e35_6.1.7600.20605_none_fcb7128823c71899.manifest
File version
File size699
Date (UTC)30-Dec-2009
Time (UTC)05:48
PlatformNot Applicable
File nameIa64_microsoft-windows-time-tool_31bf3856ad364e35_6.1.7600.20605_none_edc13566b61cd303.manifest
File version
File size2,763
Date (UTC)29-Dec-2009
Time (UTC)18:58
PlatformNot Applicable

↑ Back to the top


Keywords: kbexpertiseinter, kbfix, kbhotfixserver, kbqfe, kbautohotfix, kbsurveynew, kbprb, KB978714

↑ Back to the top

Article Info
Article ID : 978714
Revision : 1
Created on : 2/8/2010
Published on : 2/8/2010
Exists online : False
Views : 428