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The setsockopt function does not bind a PGM packet to a network interface that has more than two IP addresses on a computer that is running Windows 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7 or Windows Server 2008 R2.
  • You configure a network interface to have more than two IP addresses on the computer.
  • An application on the computer calls a setsockopt function. This function sets the Pragmatic General Multicast (PGM) socket options on the IP addresses.
In this scenario, the setsockopt function does not bind a PGM packet to the network interface that has more than two IP addresses.

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Cause

This issue occurs because of a problem in the tdx.sys driver.

The tdx.sys driver assigns IP addresses of the network interface to a buffer that is created by the application. However, the buffer size is not large enough, and the tdx.sys driver does not indicate that the buffer size is insufficient. Instead, it incorrectly returns "OK". Therefore, some IP addresses are not captured. When the setsockopt function tries to bind these IP addresses that are not captured, the setsockopt function fails.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows Server 2008 R2 on the computer.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tdx.sys6.1.7600.2064174,24011-Feb-201003:14x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tdx.sys6.1.7600.2064199,84011-Feb-201003:25x64
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tdx.sys6.1.7600.20641235,00811-Feb-201002:49IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size1,674
Date (UTC)11-Feb-2010
Time (UTC)23:27
PlatformNot applicable
File nameX86_c1da511fa1797f5bc8de252d40efe077_31bf3856ad364e35_6.1.7600.20641_none_a4332ee81c8dd7e9.manifest
File versionNot applicable
File size702
Date (UTC)11-Feb-2010
Time (UTC)23:27
PlatformNot applicable
File nameX86_microsoft-windows-tdi-over-tcpip_31bf3856ad364e35_6.1.7600.20641_none_eac4fd8e566a0320.manifest
File versionNot applicable
File size2,924
Date (UTC)11-Feb-2010
Time (UTC)07:23
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_38625f1a399d43f416c61e7110e5cb56_31bf3856ad364e35_6.1.7600.20641_none_369661988e44ad35.manifest
File versionNot applicable
File size706
Date (UTC)11-Feb-2010
Time (UTC)23:27
PlatformNot applicable
File nameAmd64_microsoft-windows-tdi-over-tcpip_31bf3856ad364e35_6.1.7600.20641_none_46e399120ec77456.manifest
File versionNot applicable
File size2,926
Date (UTC)11-Feb-2010
Time (UTC)19:29
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,906
Date (UTC)11-Feb-2010
Time (UTC)23:27
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_63b196bcba7e917603410613b14ce2f5_31bf3856ad364e35_6.1.7600.20641_none_0c3972bbe9791882.manifest
File versionNot applicable
File size704
Date (UTC)11-Feb-2010
Time (UTC)23:27
PlatformNot applicable
File nameIa64_microsoft-windows-tdi-over-tcpip_31bf3856ad364e35_6.1.7600.20641_none_eac6a18456680c1c.manifest
File versionNot applicable
File size2,925
Date (UTC)11-Feb-2010
Time (UTC)19:30
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,684
Date (UTC)11-Feb-2010
Time (UTC)23:27
PlatformNot applicable

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Keywords: kbsurveynew, kbexpertiseadvanced, kbqfe, kbautohotfix, kbhotfixserver, kbfix, KB978622

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Article Info
Article ID : 978622
Revision : 1
Created on : 4/14/2010
Published on : 4/14/2010
Exists online : False
Views : 548