Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You experience significant delays when you read the same set of files several times on a read-only volume in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

You have a set of files on a read-only volume on a computer that is running Windows 7 or Windows Server 2008 R2. When you read the files several times, the operation takes significantly longer than when the same volume is in read/write mode.

↑ Back to the top


Cause

This issue occurs because Windows 7 and Windows Server 2008 R2 do not store files in the Windows cache when a volume is in read-only mode.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows 7 or Windows Server 2008 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys6.1.7600.206171,210,24814-Jan-201007:42x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys6.1.7600.206171,657,73614-Jan-201008:19x64
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys6.1.7600.206173,556,22414-Jan-201007:03IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
X86_5cceccd3b2142417fab5a956fa6e2c9a_31bf3856ad364e35_6.1.7600.20617_none_a3e0d6b37c8c8339.manifest69214-Jan-201018:29Not Applicable
X86_microsoft-windows-ntfs_31bf3856ad364e35_6.1.7600.20617_none_a71ed07f97223833.manifest14,50814-Jan-201008:01Not Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_8a0d08fc96f8db9e889b48d10aa311a0_31bf3856ad364e35_6.1.7600.20617_none_54fa3a0849860b38.manifest69614-Jan-201018:29Not Applicable
Amd64_microsoft-windows-ntfs_31bf3856ad364e35_6.1.7600.20617_none_033d6c034f7fa969.manifest14,51414-Jan-201008:49Not Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ia64_b6bd269b61b3f7a024254c1993623f9b_31bf3856ad364e35_6.1.7600.20617_none_9ffdb41c1fd70e5a.manifest69414-Jan-201018:29Not Applicable
Ia64_microsoft-windows-ntfs_31bf3856ad364e35_6.1.7600.20617_none_a72074759720412f.manifest14,51114-Jan-201008:31Not Applicable

↑ Back to the top


Keywords: kbexpertiseinter, kbprb, kbsurveynew, kbhotfixserver, kbautohotfix, kbqfe, kbfix, KB978516

↑ Back to the top

Article Info
Article ID : 978516
Revision : 1
Created on : 2/8/2010
Published on : 2/8/2010
Exists online : False
Views : 291