Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Logoff process stops responding after you create a logoff Group Policy script on a client computer that is running Windows Vista or Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You are in an Active Directory domain network environment.
  • You create a logoff script in the Group Policy Management Console (GPMC).
  • This script includes an executable graphical user interface (GUI) application.
  • You log off a client computer that is running Windows Vista or Windows Server 2008.
In this scenario, the client computer may stop responding.

Note
  • This issue only occurs if the Tablet PC Input Service is running.
  • This issue also occurs in a workgroup environment when you create a logoff script in the Local Group Policy Editor.

↑ Back to the top


Cause

If the Tablet PC Input Service is running, the GUI application runs without a user interface when you log off the computer. Therefore, you cannot close the application. This causes the computer to stop responding.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both of these operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 1 . 22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Winlogon.exe6.0.6001.22584315,39216-Dec-200909:56x86
Winlogon.exe6.0.6002.22290314,88017-Dec-200909:37x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Winlogon.exe6.0.6001.22584407,04016-Dec-200910:24x64
Winlogon.exe6.0.6002.22290406,52817-Dec-200909:51x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Winlogon.exe6.0.6001.22584916,99216-Dec-200910:05IA-64
Winlogon.exe6.0.6002.22290916,48017-Dec-200909:45IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameX86_15d600f8cd4f6aab945ef7a7bc0f8b21_31bf3856ad364e35_6.0.6002.22290_none_9d564a9323bbaac1.manifest
File version
File size696
Date (UTC)18-Dec-2009
Time (UTC)11:05
PlatformNot Applicable
File nameX86_c245e29a6b822728116f41485eb79a80_31bf3856ad364e35_6.0.6001.22584_none_fe00fd434fdd5b7b.manifest
File version
File size696
Date (UTC)18-Dec-2009
Time (UTC)11:05
PlatformNot Applicable
File nameX86_microsoft-windows-winlogon_31bf3856ad364e35_6.0.6001.22584_none_6ffa2741ee4c553f.manifest
File version
File size21,441
Date (UTC)16-Dec-2009
Time (UTC)16:09
PlatformNot Applicable
File nameX86_microsoft-windows-winlogon_31bf3856ad364e35_6.0.6002.22290_none_71d1c815eb7e60f8.manifest
File version
File size21,441
Date (UTC)17-Dec-2009
Time (UTC)13:58
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_96e09d800a3b3cf2b53a7bc208ce9f96_31bf3856ad364e35_6.0.6002.22290_none_435e6cd6d802967c.manifest
File version
File size1,040
Date (UTC)18-Dec-2009
Time (UTC)11:05
PlatformNot Applicable
File nameAmd64_cfdf016781062f591ba10cb05bd73c70_31bf3856ad364e35_6.0.6001.22584_none_ba6f1163b6e7b322.manifest
File version
File size1,040
Date (UTC)18-Dec-2009
Time (UTC)11:05
PlatformNot Applicable
File nameAmd64_dd1e87a56452b7aaf39aaa464c35da76_31bf3856ad364e35_6.0.6001.22584_none_d4b31e268afd356c.manifest
File version
File size700
Date (UTC)18-Dec-2009
Time (UTC)11:05
PlatformNot Applicable
File nameAmd64_microsoft-windows-winlogon_31bf3856ad364e35_6.0.6001.22584_none_cc18c2c5a6a9c675.manifest
File version
File size21,483
Date (UTC)16-Dec-2009
Time (UTC)14:45
PlatformNot Applicable
File nameAmd64_microsoft-windows-winlogon_31bf3856ad364e35_6.0.6002.22290_none_cdf06399a3dbd22e.manifest
File version
File size21,483
Date (UTC)17-Dec-2009
Time (UTC)13:31
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_2394e62be48bc7b6398fd0c28c7d7d1e_31bf3856ad364e35_6.0.6001.22584_none_0c68dd7ceeeb82ad.manifest
File version
File size698
Date (UTC)18-Dec-2009
Time (UTC)11:04
PlatformNot Applicable
File nameIa64_b0820caa6cf7132563169e45f9c3aa5b_31bf3856ad364e35_6.0.6001.22584_none_b88b2d52af254ea0.manifest
File version
File size1,038
Date (UTC)18-Dec-2009
Time (UTC)11:04
PlatformNot Applicable
File nameIa64_bdd4ee81dc14e52aab5bdc632048a6f1_31bf3856ad364e35_6.0.6002.22290_none_0bca45d40c28669a.manifest
File version
File size1,038
Date (UTC)18-Dec-2009
Time (UTC)11:04
PlatformNot Applicable
File nameIa64_microsoft-windows-winlogon_31bf3856ad364e35_6.0.6001.22584_none_6ffbcb37ee4a5e3b.manifest
File version
File size21,462
Date (UTC)16-Dec-2009
Time (UTC)13:53
PlatformNot Applicable
File nameIa64_microsoft-windows-winlogon_31bf3856ad364e35_6.0.6002.22290_none_71d36c0beb7c69f4.manifest
File version
File size21,462
Date (UTC)17-Dec-2009
Time (UTC)13:03
PlatformNot Applicable

↑ Back to the top


Keywords: kbsurveynew, kbexpertiseadvanced, kbqfe, kbautohotfix, kbhotfixserver, kbfix, KB978489

↑ Back to the top

Article Info
Article ID : 978489
Revision : 1
Created on : 2/8/2010
Published on : 2/8/2010
Exists online : False
Views : 403