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The MS DTC issue that is fixed in Windows Server 2008 R2 MS DTC Hotfix Rollup Package 1


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Summary

This article describes the Microsoft Distributed Transaction Coordinator (MS DTC) issue that is fixed in Windows Server 2008 R2 MS DTC Hotfix Rollup Package 1.

Issue that is fixed in this hotfix rollup package

This hotfix rollup package fixes the following issue that was not previously documented in a Microsoft Knowledge Base article.

Consider the following scenario:
  • You have a failover cluster that is running Windows Server 2008 R2.
  • You add a MS DTC resource to the cluster. Additionally, you configure the MS DTC resource to depend on a third-party disk resource.
  • You try to bring the MS DTC resource online.
In this scenario, you cannot bring the MS DTC resource online. Additionally, an error message that resembles the following is logged in the Application log:

Log Name: System
Source: Microsoft-Windows-FailoverClustering
Date: <Date Time>
Event ID: 1146
Task Category: Resource Control Manager
Description: The cluster resource host subsystem (RHS) stopped unexpectedly. An attempt will be made to restart it. This is usually due to a problem in a resource DLL. Please determine which resource DLL is causing the issue and report the problem to the resource vendor.

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Cause

This problem occurs because the MS DTC resource cannot identify a dependent disk when a third-party disk resource is used.

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More information

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Server 2008 R2 installed to apply this hotfix rollup package.

Restart requirement

You have to restart the computer after you apply this hotfix rollup package.

Hotfix replacement information

This hotfix rollup package does not replace other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mtxclu.dll2001.12.8530.20595374,27213-Dec-200911:12x64
Msdtcprx.dll2001.12.8530.20595746,49613-Dec-200911:12x64
Xolehlp.dll2001.12.8530.2059559,39213-Dec-200911:16x64
Msdtctm.dll2001.12.8530.205951,510,91213-Dec-200911:12x64

For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mtxclu.dll2001.12.8530.20595594,94413-Dec-200908:26IA-64
Msdtcprx.dll2001.12.8530.205951,600,00013-Dec-200908:26IA-64
Xolehlp.dll2001.12.8530.20595116,73613-Dec-200908:30IA-64
Msdtctm.dll2001.12.8530.205952,867,71213-Dec-200908:26IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the ResUtilGetResourceDependency function, visit the following Microsoft Developer Network (MSDN) Web site:For more information about the ResUtilGetResourceDependencyByClass function, visit the following MSDN Web site:

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Keywords: KB978476, kbqfe, kbsurveynew, kbautohotfix, kbexpertiseadvanced

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Article Info
Article ID : 978476
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 346