Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you use the Commerce Server Staging service in Commerce Server


View products that this article applies to.

Symptoms

On a computer that is running Microsoft Commerce Server 2007 or Commerce Server 2009, you notice that the Commerce Server Staging (CSS) service throws exceptions after the service runs for some time. When this issue occurs, a log entry that resembles the following is logged in the Application log:

Event Type: Error Event Source: Commerce Server Staging Event Category: None Event ID: 61208 Description: Error occurred with the database StagingLog.mdb. Error is: System.Data.OleDb.OleDbException: System resource exceeded. at System.Data.OleDb.OleDbCommand.ExecuteCommandTextErrorHandling(OleDbHResult hr) at System.Data.OleDb.OleDbCommand.ExecuteCommandTextForSingleResult(tagDBPARAMS dbParams, Object& executeResult) at System.Data.OleDb.OleDbCommand.ExecuteCommandText(Object& executeResult) at System.Data.OleDb.OleDbCommand.ExecuteCommand(CommandBehavior behavior, Object& executeResult) at System.Data.OleDb.OleDbCommand.ExecuteReaderInternal(CommandBehavior behavior, String method) at System.Data.OleDb.OleDbCommand.ExecuteReader(CommandBehavior behavior) at System.Data.OleDb.OleDbCommand.ExecuteReader() at Microsoft.CommerceServer.Staging.Internal.ProjectDeploymentLog.GetStatusForReplication(String replicationId).


Note
This issue occurs more frequently when you create projects for Commerce Server Staging that are scheduled to run automatically.

↑ Back to the top


Cause

This issue occurs because the Staginglog.mdb database is queried frequently. This causes a to severe fragmentation of the memory that is used by the default Process heap. The CSS Service Process (Cssrv.exe) uses the Default Process Heap to allocate memory for queries to the Staginglog.mdb database. This causes the issue that is described in the "Symptoms" section.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: - Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft Commerce Server 2007 Service Pack 2 (SP2) or Microsoft Commerce Server 2009 installed to apply this hotfix. Additionally, you must have Microsoft SQL Server Compact 3.5 Service Pack 1 (SP1) installed.

Note This hotfix moves the staging log database from an Access Database to a SQL Server Compact Edition (CE) database. Therefore, SQL Server CE 3.5 SP1 is a prerequisite for the installation of this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must reopen the Commerce Server Staging management console and then restart the Commerce Server Staging service after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Commerce Server 2007
File nameFile versionFile sizeDateTimePlatform
Cssapi.dll6.0.4109.40152,40031-Mar-201014:39x86
Cssapilib.dll6.0.4109.4042,84031-Mar-201014:36x86
Microsoft.commerceserver.staging.businessdatastagingframework.dll6.0.4109.40108,48031-Mar-201014:36x86
Staginglog.sdfNot applicable86,01625-Mar-201011:18Not applicable
Commerce Server 2009
File nameFile versionFile sizeDateTimePlatform
Cs2009hotfixhelper.exe6.0.4171.2312,13602-Jun-201012:55x86
Cssapi.dll6.0.4171.23152,40001-Jun-201014:03x86
Cssapilib.dll6.0.4171.2342,84002-Jun-201012:55x86
Microsoft.commerceserver.staging.businessdatastagingframework.dll6.0.4171.23108,48002-Jun-201012:55x86
Staginglog.sdfNot applicable86,01601-Jun-201007:25Not applicable

Installation Instructions

  1. Extract the hotfix package. When you extract the hotfix package, you receive the following files.
      For Commerce Server 2007

      • CommerceServer2007SP2-KB978466-ENU.exe
      • Hotfix.txt

      For Commerce Server 2009
      • CommerceServer2007SP3-KB978466-ENU.exe
      • Hotfix.txt



  2. Install SQL Server Compact Edition (CE) 3.5 SP1.

    Note If you want to install the x64 version of SQL Server 2008 CE, you must install the x86 version before you can install the x64 version.
  3. Close the Commerce Server Staging management console, and then stop the CSS service. To stop the CSS service, open a command prompt, type the following command, and then press ENTER:
    net stop css
  4. For Commerce Server 2007, run the CommerceServer2007SP2-KB978466-ENU.exe file to apply the hotfix. For Commerce Server 2009, run the CommerceServer2007SP3-KB978466-ENU.exe file to apply the hotfix. �
  5. Run the CommerceServer2007SP2-KB978466-ENU.exe file to apply the hotfix.
  6. After the installation is complete, start the CSS service. To start the CSS service, open a command prompt, type the following command, and then press ENTER:
    net start css

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about CSS, visit the following Microsoft Developer Network (MSDN) website:To download SQL Server Compact 3.5 SP1 from the Microsoft Download Center, visit the following Microsoft website:

↑ Back to the top


Keywords: atdownload, kbautohotfix, kbexpertiseadvanced, kbsurveynew, kbqfe, kbHotfixServer, KB978466

↑ Back to the top

Article Info
Article ID : 978466
Revision : 3
Created on : 2/2/2012
Published on : 2/2/2012
Exists online : False
Views : 482