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Entered characters are unexpectedly deleted in a Web page that loads Office Web Components in Internet Explorer 8


View products that this article applies to.

Symptoms

You use Windows Internet Explorer 8 to browse a Web page that loads Office Web Components (OWC). When you enter a long string in the loaded page, the string is reinitialized every five to seven seconds. When the string is reinitialized, the characters that you have entered are unexpectedly deleted.

Note This issue occurs only when the Automatic Crash Recovery feature is enabled in Internet Explorer 8. By default, this feature is enabled after you install Internet Explorer 8.

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Cause

This issue occurs because of an error in the Automatic Crash Recovery feature of Internet Explorer 8. This error causes Internet Explorer 8 to reset the focus every five to seven seconds.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Internet Explorer 8 installed on a computer that is running one of the following operating systems:
  • Windows XP Service Pack 3 (SP3)
  • Windows Server 2003 Service Pack 2 (SP2)
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows 7
  • Windows Server 2008 R2
For more information about how to obtain a Windows XP service pack, click the following article number to view the article in the Microsoft Knowledge Base:
322389� How to obtain the latest Windows XP service pack
For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791� How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849� How to obtain the latest service pack for Windows Server 2008

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756� How to back up and restore the registry in Windows
To use one of the hotfixes in this package, you must create a registry key. To do this, follow these steps:
  1. Click Start
    , type regedit in the Search programs and files box, and then press ENTER.
    If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.
    Notes
    • If you are using Internet Explorer 8 in Windows XP, click Start, click Run, type regedit and then press ENTER.
    • If you are using Internet Explorer 8 in Windows Vista, click Start
      , type regedit in the Search box, and then press ENTER.
  2. Locate and then click the following registry subkeys:
    • On 32-bit systems:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
    • On 64-bit systems:
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\Main\FeatureControl
  3. On the Edit menu, point to New, and then click Key.
  4. Type FEATURE_RESTRICT_CRASH_RECOVERY_SAVE_KB978454, and then press ENTER.
  5. On the Edit menu, point to New, and then click DWORD Value.
  6. Type Iexplore.exe, and then press ENTER.
  7. Right-click Iexplore.exe, and then click Modify.
  8. In the Value data box, type 1, and then click OK.
  9. Exit Registry Editor.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version or the global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows XP and Windows Server 2003 file information
For all supported x86-based versions of Internet Explorer 8 for Windows XP SP3
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll8.00.6001.230075,946,36823-Mar-201011:43x86
For all supported x86-based versions of Internet Explorer 8 for Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll8.00.6001.230075,946,36823-Mar-201018:55x86
For all supported x64-based versions of Internet Explorer 8 for Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mshtml.dll8.00.6001.230079,246,20823-Mar-201016:46x64SP2Not applicable
Wmshtml.dll8.00.6001.230075,946,36823-Mar-201016:46x86SP2WOW
Windows Vista and Windows Server 2008 file information
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Internet Explorer 8 for Windows Server 2008 and for Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll8.00.6001.230075,946,36820-Mar-201014:30x86
Mshtml.tlb8.00.6001.230071,638,91220-Mar-201012:51Not applicable
For all supported x64-based versions of Internet Explorer 8 for Windows Server 2008 and for Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll8.00.6001.230079,246,20820-Mar-201015:07x64
Mshtml.tlb8.00.6001.230071,638,91220-Mar-201013:29Not applicable
Windows 7 and Windows Server 2008 R2 file information
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Internet Explorer 8 for Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft-windows-ie-htmlrendering.ptxml1,14113-Jul-200920:45Not applicable
Mshtml.dll8.00.7600.163845,966,33620-Mar-201007:41x86
Mshtml.tlb8.00.7600.163851,638,91213-Jul-200923:42Not applicable
For all supported x64-based versions of Internet Explorer 8 for Windows 7 and for Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft-windows-ie-htmlrendering.ptxml1,14113-Jul-200920:36Not applicable
Mshtml.dll8.00.7600.163849,287,68020-Mar-201007:57x64
Mshtml.tlb8.00.7600.163851,638,91213-Jul-200923:58Not applicable
Mshtml.dll8.00.7600.163845,966,33620-Mar-201007:41x86
Mshtml.tlb8.00.7600.163851,638,91213-Jul-200923:42Not applicable
Wow64_microsoft-windows-ie-htmlrendering.ptxml1,14113-Jul-200920:45Not applicable

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Workaround

To work around this issue, disable the Automatic Crash Recovery feature in Internet Explorer 8. To do this, follow these steps:
  1. On the Tools menu, click Internet Options.
  2. Click Advanced, and then clear the Enable automatic crash recovery check box.
  3. Restart Internet Explorer 8.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Internet Explorer 8 for Windows Vista and for Windows Server 2008
Collapse this tableExpand this table
File nameX86_3c88912774324aa3d2f7e1242cc3c1e3_31bf3856ad364e35_8.0.6001.23007_none_54dc4391f2818b70.manifest
File version
File size704
Date (UTC)22-Mar-2010
Time (UTC)18:10
PlatformNot applicable
File nameX86_microsoft-windows-ie-htmlrendering_31bf3856ad364e35_8.0.6001.23007_none_f6bcad3b510e3a5f.manifest
File version
File size985,552
Date (UTC)20-Mar-2010
Time (UTC)15:07
PlatformNot applicable
Additional files for all supported x64-based versions of Internet Explorer 8 for Windows Vista and for Windows Server 2008
Collapse this tableExpand this table
File nameAmd64_14eb118bcedfe295be5a687bff19e7c3_31bf3856ad364e35_8.0.6001.23007_none_fc898c469e488223.manifest
File version
File size1,056
Date (UTC)22-Mar-2010
Time (UTC)18:10
PlatformNot applicable
File nameAmd64_microsoft-windows-ie-htmlrendering_31bf3856ad364e35_8.0.6001.23007_none_52db48bf096bab95.manifest
File version
File size985,619
Date (UTC)20-Mar-2010
Time (UTC)15:57
PlatformNot applicable

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Internet Explorer 8 for Windows 7
Collapse this tableExpand this table
File nameX86_427986767fddc3ec1f14b8d0ca724917_31bf3856ad364e35_8.0.7600.20674_none_5d4b31e13c89a061.manifest
File version
File size704
Date (UTC)20-Mar-2010
Time (UTC)13:30
PlatformNot applicable
File nameX86_microsoft-windows-ie-htmlrendering_31bf3856ad364e35_8.0.7600.20674_none_2e67203013956dda.manifest
File version
File size713,762
Date (UTC)20-Mar-2010
Time (UTC)13:32
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_32fca22b2fd2d5962ca740681922db30_31bf3856ad364e35_8.0.7600.20674_none_9c25e1c8ccfb4a2a.manifest
File version
File size1,058
Date (UTC)20-Mar-2010
Time (UTC)13:30
PlatformNot applicable
File nameAmd64_c95f645725b406557ec6bd687fdc841d_31bf3856ad364e35_8.0.7600.20674_none_5a515e704e75899d.manifest
File version
File size708
Date (UTC)20-Mar-2010
Time (UTC)13:30
PlatformNot applicable
File nameAmd64_microsoft-windows-ie-htmlrendering_31bf3856ad364e35_8.0.7600.20674_none_8a85bbb3cbf2df10.manifest
File version
File size713,769
Date (UTC)20-Mar-2010
Time (UTC)13:34
PlatformNot applicable
File nameWow64_microsoft-windows-ie-htmlrendering_31bf3856ad364e35_8.0.7600.20674_none_94da66060053a10b.manifest
File version
File size712,781
Date (UTC)20-Mar-2010
Time (UTC)13:34
PlatformNot applicable

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Keywords: KB978454, kbprb, kbsurveynew, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter

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Article Info
Article ID : 978454
Revision : 2
Created on : 4/22/2010
Published on : 4/22/2010
Exists online : False
Views : 391