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The "Processor Idle Time" performance data is incorrect on a computer that is running a 64-bit version of Windows Server 2003 Service Pack 2 (SP2)


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a multiprocessor computer that is running a 64-bit version of Windows Server 2003 Service Pack 2 (SP2).
  • You use a 32-bit application to call the Performance Data Helper APIs to query the performance data for the processor idle time. For example, the application calls the PdhCollectQueryData function or the PdhGetFormattedCounterValue function to query the processor idle time information.
In this scenario, the information for the processor idle time that is returned by the 32-bit application is incorrect.

Note To verify the correctness of the returned data, you can compare it to the data that is captured by Performance Monitor.

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Cause

This issue occurs because of an issue in the Windows 32-bit on Windows 64-bit (WoW64) module. When the 32-bit application tries to query the performance data for the processor idle time, it receives the performance data for only one processor. However, the computer is a multiprocessor computer. Therefore, this behavior is incorrect.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2003 and of Windows XP Professional x64 Edition
File nameFile versionFile sizeDateTimePlatform
Wow64.dll5.2.3790.4640249,85621-Dec-200921:59x64
For all supported IA-64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Wow64.dll5.2.3790.4640497,66421-Dec-200921:59IA-64

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Workaround

To work around this issue, use a native 64-bit application to query the "Processor Idle Time" performance data.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the PdhCollectQueryData function, visit the following Microsoft Developer Network (MSDN) Web site:For more information about the PdhGetFormattedCounterValue function, visit the following MSDN Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbsurveynew, kbexpertiseadvanced, kbqfe, kbautohotfix, kbhotfixserver, kbfix, KB978334

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Article Info
Article ID : 978334
Revision : 1
Created on : 2/8/2010
Published on : 2/8/2010
Exists online : False
Views : 285