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A Microsoft Office application crashes when you try to exit the application on a computer that is running Windows Vista or Windows Server 2008


View products that this article applies to.

Symptoms

When you try to exit a Microsoft Office application on a computer that is running Windows Vista or Windows Server 2008, the application crashes.

This problem typically occurs when one of the following conditions is true:
  • You browse to the Review tab in the Office application. Then, you use the Ink feature in the Office application.
  • You use the Pen or the Highlighter features in the Slide Show mode of Microsoft Office PowerPoint.

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Cause

This problem occurs because Rtscom.dll incorrectly unregisters an exception handler when Rtscom.dll is unloaded from a process.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 1 . 22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Inkdiv.dll6.0.6001.22577276,99208-Dec-200919:58x86
Inked.dll6.0.6001.22577217,60008-Dec-200919:58x86
Inkobj.dll6.0.6001.225771,403,90408-Dec-200919:58x86
Journal.dll6.0.6001.22577936,96008-Dec-200919:58x86
Rtscom.dll6.0.6001.22577153,60008-Dec-200920:00x86
Inkdiv.dll6.0.6002.22283276,99208-Dec-200919:35x86
Inked.dll6.0.6002.22283217,60008-Dec-200919:35x86
Inkobj.dll6.0.6002.222831,404,41608-Dec-200919:35x86
Journal.dll6.0.6002.22283936,96008-Dec-200919:35x86
Rtscom.dll6.0.6002.22283153,60008-Dec-200919:38x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Inkdiv.dll6.0.6001.22577354,81608-Dec-200920:31x64
Inked.dll6.0.6001.22577276,48008-Dec-200920:31x64
Inkobj.dll6.0.6001.225772,106,88008-Dec-200920:31x64
Journal.dll6.0.6001.225771,447,93608-Dec-200920:31x64
Rtscom.dll6.0.6001.22577177,66408-Dec-200920:34x64
Inkdiv.dll6.0.6002.22283354,81608-Dec-200919:29x64
Inked.dll6.0.6002.22283276,48008-Dec-200919:29x64
Inkobj.dll6.0.6002.222832,106,88008-Dec-200919:29x64
Journal.dll6.0.6002.222831,447,93608-Dec-200919:29x64
Rtscom.dll6.0.6002.22283177,15208-Dec-200919:31x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameUpdate.mum
File versionNot Applicable
File size2,375
Date (UTC)09-Dec-2009
Time (UTC)10:18
PlatformNot Applicable
File nameX86_aee03a542e34b0bd744fff7cd20ba1ed_31bf3856ad364e35_6.0.6002.22283_none_88b1a78ef33655d0.manifest
File versionNot Applicable
File size716
Date (UTC)09-Dec-2009
Time (UTC)10:18
PlatformNot Applicable
File nameX86_df023ddcdc18c6c1babaec96131ec77a_31bf3856ad364e35_6.0.6001.22577_none_3a189f293c657b35.manifest
File versionNot Applicable
File size716
Date (UTC)09-Dec-2009
Time (UTC)10:18
PlatformNot Applicable
File nameX86_microsoft-windows-t..platform-comruntime_31bf3856ad364e35_6.0.6001.22577_none_cad57ece505f6b31.manifest
File versionNot Applicable
File size404,902
Date (UTC)08-Dec-2009
Time (UTC)21:57
PlatformNot Applicable
File nameX86_microsoft-windows-t..platform-comruntime_31bf3856ad364e35_6.0.6002.22283_none_ccad1fa24d9176ea.manifest
File versionNot Applicable
File size404,902
Date (UTC)08-Dec-2009
Time (UTC)21:37
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_970c845a49abc924e9294a09cfe37031_31bf3856ad364e35_6.0.6001.22577_none_1fe6c4592302fe61.manifest
File versionNot Applicable
File size1,080
Date (UTC)09-Dec-2009
Time (UTC)10:18
PlatformNot Applicable
File nameAmd64_a18c699fdf3f8ebc96704716fb9ac659_31bf3856ad364e35_6.0.6002.22283_none_55016f459b02bb13.manifest
File versionNot Applicable
File size1,080
Date (UTC)09-Dec-2009
Time (UTC)10:18
PlatformNot Applicable
File nameAmd64_microsoft-windows-t..platform-comruntime_31bf3856ad364e35_6.0.6001.22577_none_26f41a5208bcdc67.manifest
File versionNot Applicable
File size404,619
Date (UTC)09-Dec-2009
Time (UTC)00:24
PlatformNot Applicable
File nameAmd64_microsoft-windows-t..platform-comruntime_31bf3856ad364e35_6.0.6002.22283_none_28cbbb2605eee820.manifest
File versionNot Applicable
File size404,619
Date (UTC)08-Dec-2009
Time (UTC)21:18
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,393
Date (UTC)09-Dec-2009
Time (UTC)10:18
PlatformNot Applicable
File nameX86_microsoft-windows-t..platform-comruntime_31bf3856ad364e35_6.0.6001.22577_none_cad57ece505f6b31.manifest
File versionNot Applicable
File size404,902
Date (UTC)08-Dec-2009
Time (UTC)21:57
PlatformNot Applicable
File nameX86_microsoft-windows-t..platform-comruntime_31bf3856ad364e35_6.0.6002.22283_none_ccad1fa24d9176ea.manifest
File versionNot Applicable
File size404,902
Date (UTC)08-Dec-2009
Time (UTC)21:37
PlatformNot Applicable

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Keywords: kbprb, kbsurveynew, kbexpertiseadvanced, kbhotfixserver, kbautohotfix, kbqfe, kbfix, KB978244

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Article Info
Article ID : 978244
Revision : 2
Created on : 4/16/2010
Published on : 4/16/2010
Exists online : False
Views : 271