Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: You receive a System.AccessViolationException exception in the Commerce Server Profile Service when you visit a Commerce Server 2007 SP2 or Commerce Server 2009 Web site


View products that this article applies to.

Symptoms

When you access a Microsoft Commerce Server 2007 SP2 or Commerce Server 2009 Web site, you receive the following error message:
Server Error in '/' Application.
Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
Exception Details: System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
Stack Trace: �
Note For more information about the stack trace, refer to the "More Information" section.

When this problem occurs, you must restart the application pool in Internet Information Services (IIS) Manager to make the Commerce Server site function correctly.

↑ Back to the top


Cause

This problem occurs because of an error in the Commerce Server Profile Service.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: - Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Commerce Server 2007 SP2 or Commerce Server 2009 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Commerce Server 2007 SP2
File nameFile versionFile sizeDateTimePlatform
Csdwutil.dll6.0.4109.41552,78409-Apr-201011:19x86
Csdwutil.dll6.0.4109.41801,61609-Apr-201011:19x64
Commerce Server 2009
File nameFile versionFile sizeDateTimePlatform
Csdwutil.dll6.0.4171.12552,78426-Nov-200912:50x86
Csdwutil.dll6.0.4171.12801,61626-Nov-200912:50x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the CommerceProfileModule class, visit the following Microsoft Developer Network (MSDN) Web site:

↑ Back to the top


Stack trace information

[AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.]
  Microsoft.CommerceServer.Interop.Profiles.ProfileServiceClass.Initialize(String sConfigStore, String sCatalog) +0
  Microsoft.CommerceServer.Runtime.Profiles.ProfileContext..ctor(String profileServiceConnectionString, String providerConnectionString, String bdaoConnectionString, DebugContext debugContext) +806
  Microsoft.CommerceServer.Runtime.Profiles.CommerceProfileModule.CreateProfileContext() +812
  Microsoft.CommerceServer.Runtime.Profiles.CommerceProfileModule.get_ProfileContext() +127
  Microsoft.CommerceServer.Runtime.Profiles.CommerceProfileModule.OnBeginRequest(Object sender, EventArgs e) +24
  System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +176
  System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +177

↑ Back to the top


Keywords: KB977980, kbqfe, kbsurveynew, kbautohotfix, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 977980
Revision : 3
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 466