Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot edit a transport rule in Exchange Server 2010 Management Console after you import the rule from Exchange Server 2007


View products that this article applies to.

Symptoms

After you import a transport rule into Microsoft Exchange Server 2010 from Microsoft Exchange Server 2007, you cannot edit the rule in Exchange Server 2010 Management Console. The exported transport rule resembles the following in the XML file:
<rules name="Transport14">
 <rule name="Unclassified">
 <condition>
 <and>
  <true /> 
  </and>
  </condition>
 <action name="PrependSubject">
  <argument value="(SBU)" /> 
  </action>
 <action name="ApplyDisclaimerWithSeparator">
  <argument value="Append" /> 
  <argument value="Classification: Unclassified" /> 
  <argument value="Arial" /> 
  <argument value="Smallest" /> 
  <argument value="Green" /> 
  <argument value="Wrap" /> 
  <argument value="WithSeparator" /> 
  </action>
  </rule>
</rules>

↑ Back to the top


Cause

The issue that is described in the "Symptoms" section occurs after the transport rule that has the ApplyDisclaimer rule action is imported into Exchange Server 2010 from Exchange Server 2007 SP2. By design, the rule action is changed from ApplyDisclaimer to Applyhtmldisclaimer in Exchange Server 2010. However, if the transport rule includes a rule action other than the ApplyDisclaimer rule action or the ApplyDisclaimerWithSeperator rule action, the conversion from "ApplyDisclaimer" to "Applyhtmldisclaimer" fails.

Note When you import the transport rule from Exchange Server 2007 into Exchange Server 2010, the rule action should be converted to Applyhtmldisclaimer.

↑ Back to the top


Workaround

To work around this issue, re-create the transport rule that has the ApplyDisclaimer rule action in Exchange Server 2010.

↑ Back to the top


Resolution

This hotfix is scheduled to be included in Exchange Server 2010 Service Pack 1.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB977965, kbsurveynew, kbtshoot, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 977965
Revision : 2
Created on : 1/18/2010
Published on : 1/18/2010
Exists online : False
Views : 418