Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The system language is changed or you receive a Stop error after you restart a computer that is running a preinstalled version of Windows 7: "0x00000021a"


View products that this article applies to.

Symptoms

Consider the following scenario:

  • You have a computer that has Windows 7 preinstalled.
  • You start the computer for the first time. Therefore, the Out of Box Experience (OOBE) wizard starts.
  • You set the display language to Chinese or to Portuguese.

    Note You notice that there are at least two entries for the language that you select.

In this scenario, you experience one or both of the following issues:
  • After you restart the computer, the system display language is changed to a random language.
  • When you try to restart the computer, the system cannot start and you receive a Stop error that resembles the following:
    STOP 0x0000021a
    Note This issue may occur up to several days after you start the computer for the first time.

Note These issues may also occur if you use Language Pack Installer (Lpksetup.exe) to manually remove a language pack on a computer that is running Windows 7 Ultimate, or Windows 7 Enterprise, or Windows Server 2008 R2.

↑ Back to the top


Cause

These issues occur because the Lpksetup.exe incorrectly removes the language pack of the system display language.

After you run the OOBE wizard, Lpksetup.exe automatically removes the unused language packs. When it removes language packs, Lpksetup.exe compares language names instead of language codes. If a removed language and the current system language have the same language name, the current system language pack is also removed. For example, ZH-TW and ZH-HK share the name "Chinese."

↑ Back to the top


Resolution

To resolve this problem, download the hotfix that is described in this article, and then apply the hotfix by using the instructions from your computer manufacturer. For information about how to contact your computer manufacturer, visit the following Microsoft Web site:

Note If the crash occurs because you manually remove a language pack by using Lpksetup.exe, you may have to repair the operating system before you can install the hotfix. To repair the system, use a system repair disc. For more information about system repair discs, visit the following Microsoft Web site:

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The Global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both of these operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Langcleanupsysprepaction.dll6.1.7600.2058626,62401-Dec-200917:45x86
Lpksetup.exe6.1.7600.20586477,69601-Dec-200917:43x86
Lpksetupproxyserv.dll6.1.7600.163856,14414-Jul-200901:15x86
Lpremove.exe6.1.7600.1638561,44014-Jul-200901:14x86
Muilanguagecleanup.dll6.1.7600.1638510,24014-Jul-200901:15x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Langcleanupsysprepaction.dll6.1.7600.2058635,84001-Dec-200917:49x64
Lpksetup.exe6.1.7600.20586652,80001-Dec-200917:45x64
Lpksetupproxyserv.dll6.1.7600.163858,19214-Jul-200901:41x64
Lpremove.exe6.1.7600.1638571,16814-Jul-200901:39x64
Muilanguagecleanup.dll6.1.7600.1638512,80014-Jul-200901:41x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Langcleanupsysprepaction.dll6.1.7600.2058653,24801-Dec-200917:41IA-64
Lpksetup.exe6.1.7600.205861,284,09601-Dec-200917:38IA-64
Lpksetupproxyserv.dll6.1.7600.1638511,26414-Jul-200901:46IA-64
Lpremove.exe6.1.7600.16385136,70414-Jul-200901:44IA-64
Muilanguagecleanup.dll6.1.7600.1638529,18414-Jul-200901:47IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
X86_8e855d8b4a58a97126ac9a62ff69c87f_31bf3856ad364e35_6.1.7600.20586_none_7b865735fbefdfd4.manifestNot Applicable69601-Dec-200921:15Not Applicable
X86_microsoft-windows-lpksetup_31bf3856ad364e35_6.1.7600.20586_none_21ba5627e6e8c2d5.manifestNot Applicable69,34001-Dec-200921:26Not Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Amd64_c345b0eb3f0c11bfd8cc0dbe4b768284_31bf3856ad364e35_6.1.7600.20586_none_a680417a4e9bde1e.manifestNot Applicable70001-Dec-200921:15Not Applicable
Amd64_microsoft-windows-lpksetup_31bf3856ad364e35_6.1.7600.20586_none_7dd8f1ab9f46340b.manifestNot Applicable69,34401-Dec-200921:35Not Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ia64_8ef4f584d900a9237be74e323be77879_31bf3856ad364e35_6.1.7600.20586_none_f8b36db8635441a9.manifestNot Applicable69801-Dec-200921:15Not Applicable
Ia64_microsoft-windows-lpksetup_31bf3856ad364e35_6.1.7600.20586_none_21bbfa1de6e6cbd1.manifestNot Applicable69,34201-Dec-200921:15Not Applicable

↑ Back to the top


Keywords: kbfix, kbautohotfix, kbexpertisebeginner, kbsurveynew, kbqfe, kbhotfixserver, kb

↑ Back to the top

Article Info
Article ID : 977911
Revision : 3
Created on : 4/23/2018
Published on : 4/23/2018
Exists online : False
Views : 284