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FIX: You cannot create products by using a product definition that contains many multilingual product properties in Commerce Server 2007 or in Commerce Server 2009


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In Microsoft Commerce Server 2007 or in Microsoft Commerce Server 2009, you create a product definition that contains many multilingual product properties.
  • The multilingual product properties are specified to use default values.
  • You create a catalog and then select many languages for the catalog.
  • In the catalog, you try to create a new product by using the product definition that you created.
In this scenario, you cannot create the new product. Additionally, you receive an error message that resembles the following:
An exception occurred in the 'CatalogWebService' Web service. Exception details follow:
Microsoft.CommerceServer.Catalog.CatalogDatabaseException: Failed to apply default values. ---> System.Data.SqlClient.SqlException: The incoming tabular data stream (TDS) remote procedure call (RPC) protocol stream is incorrect. Too many parameters were provided in this RPC request. The maximum is 2100.
For example, you create a product definition that contains 150 multilingual properties. You select 14 languages for a catalog. When you try to create a new product in the catalog, you experience this problem.

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Cause

Commerce Server 2007 and Commerce Server 2009 use a single SQL UPDATE statement to apply all default values to the product properties in the back-end Microsoft SQL Server database. When the number of parameters for the statement exceeds the maximum number of parameters that SQL Server allows, SQL Server reports an error to Commerce Server.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Commerce Server 2007 Service Pack 2 (SP2) or Commerce Server 2009 installed to apply this hotfix.

Restart information

You do not have to restart the computer after you apply this hotfix. However, you must restart Internet Information Services (IIS) and the Commerce Server Catalog Import Host COM+ application after you apply this hotfix. To restart IIS, open a command prompt, type the following command, and then press ENTER:
IISRESET /RESTART
Note This procedure stops and then restarts all IIS services that are running.

Registry information

You do not have to change the registry.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For Commerce Server 2007 SP2
File nameFile versionFile sizeDateTimePlatform
Microsoft.catalogserver.dll6.0.4109.33751,47230-Nov-200910:33x86
Microsoft.commerceserver.catalog.dll6.0.4109.33960,38430-Nov-200910:48x86
For Commerce Server 2009
File nameFile versionFile sizeDateTimePlatform
Microsoft.catalogserver.dll6.0.4171.13751,47202-Dec-200909:10x86
Microsoft.commerceserver.catalog.dll6.0.4171.13960,38402-Dec-200910:28x86

Known issues

After you install or uninstall the hotfix for Commerce Server 2009, both Commerce Server 2009 and Commerce Server 2007 appear on the Start menu. You can safely ignore or delete the Commerce Server 2007 menu item.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Workaround

To work around this problem, do not assign default values to the multilingual catalog properties.

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More information

For more information about how to manage catalog and inventory schema, visit the following Microsoft Developer Network (MSDN) Web site:

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbexpertiseadvanced, kbfix, kbautohotfix, kbsurveynew, kbqfe, KB977779

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Article Info
Article ID : 977779
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 407