Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Update fails when you use a CDO application to update a recurrence task on Exchange Server 2010


View products that this article applies to.

Symptoms

When you use a Collaboration Data Objects (CDO) application to update a recurrence task on Microsoft Exchange Server 2010, the update fails.
For example, you create a weekly recurrence task and remove a recurrence flag of the task by using a CDO application. After you remove the recurrence flag, you find that the task is still a recurrence task in Microsoft Office Outlook.

↑ Back to the top


Cause

When you remove the recurrence flag for a recurrence task, the corresponding recurrence property value of the task is set as "NULL". However, the related recurrence property value is also checked internally. This internal check treats the "NULL" value as an abnormal value.

↑ Back to the top


Resolution

To resolve this problem, install the following update rollup:
976573� Description of Update Rollup 1 for Exchange Server 2010

↑ Back to the top


Keywords: KB977560, kbhotfixrollup, kbexpertiseinter, kbqfe, kbfix, kbsurveynew

↑ Back to the top

Article Info
Article ID : 977560
Revision : 1
Created on : 12/9/2009
Published on : 12/9/2009
Exists online : False
Views : 382