Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FSRM Classification Rules repeatedly classify the same files, and reports do not update


View products that this article applies to.

Symptoms

The Windows Server 2008 R2 File Server Resource Manager (FSRM) includes a new capability called Classification Management. To use this feature, you create a classification rule for a specific group of files within one or more Distributed File System Replication (DFSR) Read-Only replicated folders and then you run the classification rule on these folders. Running the classification rule generates a report that lists each file that is being classified.

When you run this new classification rule again, the generated report lists the same files in the DFSR Read-Only replicated folders. Typically, only new files are listed in the report.

Additionally, the FSRM Error XML file also lists the following error message for each file that is classified:
Message="HRESULT = 0x80070005 (Access is denied.)"
The FSRM XML file is located in the %systemdrive%\Storagereports folder.

↑ Back to the top


Cause

This issue occurs because FSRM File Classification is incompatible with DFSR Read-Only replicated folders. The file system filter driver DFSRRO.sys blocks all local changes to files in a DFSR Read-Only replicated folder. This behavior is by design. Because FSRM stores classification information as alternate data stream information in each file, DFSRRO.sys will block FSRM from storing this information.

↑ Back to the top


Resolution

To resolve this issue, use one of the following methods:
  • Do not use FSRM classification rules on folders that are set to DFSR Read-Only.
  • Do not configure DFSR Read-Only replication on folders that are using FSRM Classification Rules.

↑ Back to the top


Keywords: KB977520, kbprb, kbsurveynew, kbtshoot, kbexpertiseinter, kbfilesystems

↑ Back to the top

Article Info
Article ID : 977520
Revision : 1
Created on : 11/16/2009
Published on : 11/16/2009
Exists online : False
Views : 250