Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: BizTalk Server 2006 R2 does not correctly parse MIME or S/MIME messages that are signed or encrypted


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create a receive location to receive and to process MIME and S/MIME messages in Microsoft BizTalk Server 2006 R2.
  • You use a pipeline that includes the MIME/SMIME Decoder pipeline component in the receive location.
  • You receive a signed or encrypted MIME or S/MIME message in BizTalk Server 2006 R2.
In this scenario, you may experience one of the following two problems:

Problem 1

The message is suspended. Additionally, an error message that resembles the following is logged in the Application log:
Event Type: Error
Event Source: BizTalk Server 2006
Event Category: BizTalk Server 2006
Event ID: 5753
Description: A message received by adapter "<Adapter Name>" on receive location "<Receive Location Name>" with URI "<URI>" is suspended.
Error details: There was a failure executing the receive pipeline: "<Pipeline name>, <Pipeline assembly name>, Version=1.0.0.0, Culture=neutral, PublicKeyToken=<Token>" Source: "MIME/SMIME decoder"
Receive Port: "<Receive Port Name>" URI: "<URI>" Reason: There was an authentication failure. "Failed to decode the S/MIME message. The S/MIME message may not be valid.."

Problem 2

The message is received by BizTalk Server 2006 R2. However, the MIME boundary is included as part of the message. Therefore, the received message is incorrect.

Note These two problems also occur when you use the POP3 adapter in the receive location.

↑ Back to the top


Cause

This problem occurs because of an error in the Exsmime.dll library that is included in BizTalk Server 2006 R2. Because of this error, the MIME/SMIME Decoder pipeline component does not correctly parse MIME and S/MIME messages under certain conditions.

↑ Back to the top


Resolution

To resolve this problem, apply Microsoft BizTalk Server 2006 R2 Service Pack 1. For more information about BizTalk Server 2006 R2 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:
974563� List of Microsoft BizTalk Server hot fixes that are included in BizTalk Server 2006 R2 Service Pack 1

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about how to configure certificates for MIME and S/MIME messages, visit the following Microsoft Developer Network (MSDN) Web site: For more information about BizTalk Server hot fixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907� Information on BizTalk Server hot fixes

↑ Back to the top


Keywords: kbautohotfix, kbbtspipeline, kbbiztalk2006r2sp1fix, kbsurveynew, kbqfe, kbhotfixserver, kbexpertiseadvanced, KB977473

↑ Back to the top

Article Info
Article ID : 977473
Revision : 1
Created on : 2/9/2010
Published on : 2/9/2010
Exists online : False
Views : 376