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FIX: High CPU usage occurs when you back up or export configuration information for ISA Server 2006 or for Forefront TMG 2010


View products that this article applies to.

Symptoms

You create a policy rule that references a large domain name set in Microsoft Internet Security and Acceleration (ISA) Server 2006. When you back up or export configuration information for ISA Server 2006 or Microsoft Forefront Threat Management Gateway (TMG) 2010, you experience high CPU usage.

Note The supported fix for Microsoft TMG 2010 is included in Forefront TMG 2010 Service Pack 1 (SP1).

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Cause

This problem occurs because the large domain name set is copied several times to the backup file. This behavior uses a lot of CPU resources.

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Resolution

Service pack information

This problem is fixed in Forefront TMG 2010 Service Pack 1.

For more information about how to obtain Forefront TMG 2010 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:
981324� List of problems that are fixed in Forefront Threat Management Gateway 2010 Service Pack 1

Hotfix rollup information


To resolve this problem, install the hotfix rollup package that is described in the following Microsoft Knowledge Base article:
977530� Description of the ISA Server 2006 hotfix package: Description of the ISA Server 2006 hotfix package: December 8, 2009

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756� How to back up and restore the registry in Windows
To enable this hotfix, follow these steps.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAT\Stingray\Debug\Storage


    Note If this subkey does not exist, create this subkey.
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type STG_OPTIMIZE_MULTI_REF_EXPORT, and then press ENTER.
  5. Right-click
    STG_OPTIMIZE_MULTI_REF_EXPORT
    , and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. On the File menu, click Exit to exit Registry Editor.
We recommend that you also follow these steps.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAT\Stingray\Debug\COM


    Note If this subkey does not exist, create this subkey.
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type DO_NOT_BEAUTIFY, and then press ENTER.
  5. Right-click
    DO_NOT_BEAUTIFY
    , and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. On the File menu, click Exit to exit Registry Editor.

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Workaround

To work around this issue, detach the domain name set from all policy rules before export. Then, reattach the domain name set from all policy rules after backup.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Forefront TMG 2010 Service Pack 1.

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References

For more information about how to back up or export configuration information for ISA Server 2006, visit the following Microsoft Web site:
http://support.microsoft.com/kb/935847

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Keywords: KB977427, kbexpertiseadvanced, kbqfe, kbsurveynew

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Article Info
Article ID : 977427
Revision : 7
Created on : 10/6/2011
Published on : 10/6/2011
Exists online : False
Views : 327