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An SqlBulkCopy operation may fail on a computer that is running Windows Server 2003 SP2 under a heavy load situation


View products that this article applies to.

Symptoms

Under a heavy stress situation, an SqlBulkCopy operation may fail. Additionally, you may receive one of the following error messages:
The incoming tabular data stream (TDS) protocol stream is incorrect. The TDS headers contained errors.
A transport-level error has occurred when receiving results from the server. (provider: TCP Provider, error: 0.
An existing connection was forcibly closed by the remote host.) - Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

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Cause

This issue is caused by the TCP/IP driver (Tcpip.sys).

The SqlBulkCopy operation relies on the TCP/IP driver to transfer data. However, the TCP/IP driver may incorrectly cancel some I/O request packet (IRP) requests when some data fills the buffer under a heavy stress situation. Therefore, the TCP/IP driver does not transfer all received data to the above layers. This behavior causes the SqlBulkCopy operation to fail.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows XP and Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003

File nameFile versionFile sizeDateTimePlatformSP requirement
Tcpip.sys5.2.3790.4619400,89614-Nov-200900:48x86SP2
W03a3409.dll5.2.3790.459043,52016-Sep-200912:16x86SP2
For all supported x64-based versions of Windows Server 2003 and of Windows XP Professional x64 Edition

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Tcpip.sys5.2.3790.4619798,72015-Nov-200916:01x64SP2Not Applicable
W03a3409.dll5.2.3790.459044,03215-Nov-200916:01x64SP2Not Applicable
Ww03a3409.dll5.2.3790.459043,52015-Nov-200916:01x86SP2WOW
For all supported IA-64-based versions of Windows Server 2003

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Tcpip.sys5.2.3790.46191,336,83215-Nov-200915:59IA-64SP2Not Applicable
W03a3409.dll5.2.3790.459042,49615-Nov-200915:59IA-64SP2Not Applicable
Ww03a3409.dll5.2.3790.459043,52015-Nov-200915:59x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the SqlBulkCopy class, visit the following Microsoft Web site:
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbqfe, kbhotfixserver, kbsurveynew, kbautohotfix, kbexpertiseinter, kbexpertiseadvanced, kbbug, kbfix, KB977291

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Article Info
Article ID : 977291
Revision : 1
Created on : 12/28/2009
Published on : 12/28/2009
Exists online : False
Views : 328