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No private key is associated with a certificate after you successfully install the certificate on a computer that is running Windows 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

On a computer that is running Windows 7 or Windows Server 2008 R2, you install a certificate that contains a private key from an external device. After you do this, you receive a message that states that the certificate was installed successfully. This occurs even if the private key is not associated with the certificate.

Additionally, when you open the installed certificate in Certificate Management, nothing indicates that the private key is not associated to that certificate. Therefore, you cannot determine whether you can use this certificate to decrypt data.

Note You can use one of the following methods to install a certificate:
  • Run the Certificate Import Wizard.
  • Run an application that calls the IX509Enrollment::InstallResponse method.

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Cause

This problem occurs because the IX509Enrollment::InstallResponse method does not report an error if the private key is not associated with the certificate during the certificate installation.

Note The Certificate Import Wizard also uses the IX509Enrollment::InstallResponse method to install certificates.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you computer must be running Windows 7 or Windows Server 2008 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time and with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes

Important Windows 7 and Windows Server 2008 R2 hotfixes are included in the same packages. However, only one of these products may be listed on the "Hotfix Request" page. To request the hotfix package that applies to both Windows 7 and Windows Server 2008 R2, just select the product that is listed on the page.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Cryptui.dll6.1.7600.205671,003,52005-Nov-200909:33x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Cryptui.dll6.1.7600.205671,065,98405-Nov-200912:50x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Cryptui.dll6.1.7600.205671,609,21605-Nov-200908:39IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the IX509Enrollment::InstallResponse method, visit the following Microsoft Web site:

How to determine whether a private key is associated with a certificate

  1. Open Certificate Management. To do this, click Start
    , type Certmgr.msc in the Start Search box, and then press ENTER.

    If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.
  2. Locate the certificate and then double-click to open it.
  3. On the General tab, verify that the "You have a private key that corresponds to this certificate" message is displayed.
    • If this message appears, it indicates that a private key is associated with the certificate.
    • If this message does not appear, it indicates that a private key is not associated with the certificate.

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Package_for_kb977222_rtm~31bf3856ad364e35~x86~~6.1.1.0.mumNot Applicable1,94705-Nov-200914:41Not Applicable
X86_microsoft-windows-cryptui-dll_31bf3856ad364e35_6.1.7600.20567_none_8665f09f12828045.manifestNot Applicable2,72805-Nov-200910:01Not Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-cryptui-dll_31bf3856ad364e35_6.1.7600.20567_none_e2848c22cadff17b.manifestNot Applicable2,73205-Nov-200913:30Not Applicable
Package_for_kb977222_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNot Applicable2,87905-Nov-200914:41Not Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-cryptui-dll_31bf3856ad364e35_6.1.7600.20567_none_8667949512808941.manifestNot Applicable2,73005-Nov-200910:25Not Applicable
Package_for_kb977222_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mumNot Applicable1,95805-Nov-200914:41Not Applicable
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbhotfixserver, kbautohotfix, kbsurveynew, kbfix, kbqfe, kbexpertiseadvanced, KB977222

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Article Info
Article ID : 977222
Revision : 2
Created on : 12/8/2009
Published on : 12/8/2009
Exists online : False
Views : 543