Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The existing PPTP connections to a VPN server that is hosted in a Windows Server 2003-based NLB farm or in a Windows Server 2008 R2-based NLB farm do not work after a new node is added to the NLB farm


View products that this article applies to.

Symptoms

Consider the following scenario:
  • A Network Load Balancing (NLB) farm is created by using some computers that are running Windows Server 2003 Service Pack 2 (SP2) or Windows Server 2008 R2.
  • Some virtual private network (VPN) servers are hosted in the NLB farm.
  • You create some Point-to-Point Tunneling Protocol (PPTP) connections to the VPN servers through the NLB farm.
  • A new NLB node is added to the NLB farm.
In this scenario, the existing PPTP connections do not work after the convergence is finished. If you analyze the captured network trace, you find that all Generic Routing Encapsulation packets over the PPTP connections are dropped by NLB.

↑ Back to the top


Cause

The issue is caused by the Network Load Balancing (NLB) component.

After a new NLB node is added to the NLB farm, and after the convergence is finished, some active connections that are connected to the first NLB node are transferred to the new one for load balancing. However, some connection attributes are not transferred correctly. Therefore, the NLB component drops all Generic Routing Encapsulation packets.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2) or Windows Server 2008 R2.
For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KB977172.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003 SP2

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wlbs.sys5.2.3790.4621169,98417-Nov-200919:36x86
For all supported x64-based versions of Windows Server 2003 SP2

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wlbs.sys5.2.3790.4621280,57617-Nov-200920:49x64
For all supported IA-64-based versions of Windows Server 2003 SP2

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wlbs.sys5.2.3790.4621396,80018-Nov-200901:42IA-64
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Nlb.sys6.1.7600.20757339,96817-Jul-201006:22x64
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Nlb.sys6.1.7600.20757778,24017-Jul-201005:22IA-64

↑ Back to the top


Workaround

Workaround for Windows Server 2003

To work around the issue, restart all NLB nodes at the same time.

Workaround for Windows Server 2008 R2

To work around the issue, restart all NLB nodes at the same time.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_d4e3cdfd263857d569ee6f5fefe88af3_31bf3856ad364e35_6.1.7600.20757_none_bf9a7f009033ea87.manifest
File versionNot Applicable
File size726
Date (UTC)17-Jul-2010
Time (UTC)11:40
PlatformNot Applicable
File nameAmd64_microsoft-windows-n..ncing-networkdriver_31bf3856ad364e35_6.1.7600.20757_none_0aaafc564b1e7461.manifest
File versionNot Applicable
File size2,669
Date (UTC)17-Jul-2010
Time (UTC)08:53
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,689
Date (UTC)17-Jul-2010
Time (UTC)11:40
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_150b9419597a6de8cb4be9f6dfd849ff_31bf3856ad364e35_6.1.7600.20757_none_98ce845c94bfb3e8.manifest
File versionNot Applicable
File size724
Date (UTC)17-Jul-2010
Time (UTC)11:40
PlatformNot Applicable
File nameIa64_microsoft-windows-n..ncing-networkdriver_31bf3856ad364e35_6.1.7600.20757_none_ae8e04c892bf0c27.manifest
File versionNot Applicable
File size2,667
Date (UTC)17-Jul-2010
Time (UTC)08:50
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,461
Date (UTC)17-Jul-2010
Time (UTC)11:40
PlatformNot Applicable

↑ Back to the top


Keywords: kbqfe, kbHotfixServer, kbsurveynew, kbautohotfix, kbexpertiseinter, kbbug, kbfix, KB977172

↑ Back to the top

Article Info
Article ID : 977172
Revision : 3
Created on : 10/10/2011
Published on : 10/10/2011
Exists online : False
Views : 315