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You are unable to diagnose whether a snapshot creation failure is caused by issues in VSS hardware providers running in Windows 7 and in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • A Volume Shadow Copy Service (VSS) hardware provider is installed on a computer that is running Windows 7 or Windows Server 2008 R2.
  • You run an application to create a snapshot by using VSS.
  • An error occurs in the VSS hardware provider when the application calls any of the following methods:
    • IVssProviderCreateSnapshotSet::PostFinalCommitSnapshots
    • IVssProviderCreateSnapshotSet::PreFinalCommitSnapshots
  • The snapshot is not created because of this hardware problem.
In this scenario, you cannot diagnose the snapshot creation failure if this issue is caused by the error in the VSS hardware provider.

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Cause

This problem occurs because VSS ignores the returned code from these methods when the errors occur in the VSS hardware provider.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows 7 or Windows Server 2008 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

To avoid restarting the computer, stop VSS before you apply this hotfix. To stop VSS, follow these steps:
  1. Click Start, type Services.msc in the Search box, and then click Services.msc.
  2. In the Services Microsoft Management Console (MMC) snap-in window, right-click Volume Shadow Copy Service, and then click Stop.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Vssvc.exe6.1.7600.206171,026,04814-Jan-201007:36x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Vssvc.exe6.1.7600.206171,600,51214-Jan-201008:10x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Vssvc.exe6.1.7600.206172,170,36814-Jan-201006:52IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size1,618
Date (UTC)14-Jan-2010
Time (UTC)18:28
PlatformNot applicable
File nameX86_45e798460b56061cb353b145c380f714_31bf3856ad364e35_6.1.7600.20617_none_7dced9406c5c73d3.manifest
File versionNot applicable
File size698
Date (UTC)14-Jan-2010
Time (UTC)18:28
PlatformNot applicable
File nameX86_microsoft-windows-vssservice_31bf3856ad364e35_6.1.7600.20617_none_5b7a7539920e1267.manifest
File versionNot applicable
File size18,235
Date (UTC)14-Jan-2010
Time (UTC)07:58
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_30211b297a9cf38d6be475cd115ed777_31bf3856ad364e35_6.1.7600.20617_none_dbcd23da2c17c999.manifest
File versionNot applicable
File size702
Date (UTC)14-Jan-2010
Time (UTC)18:28
PlatformNot applicable
File nameAmd64_microsoft-windows-vssservice_31bf3856ad364e35_6.1.7600.20617_none_b79910bd4a6b839d.manifest
File versionNot applicable
File size18,241
Date (UTC)14-Jan-2010
Time (UTC)08:46
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,850
Date (UTC)14-Jan-2010
Time (UTC)18:28
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_c8f6dca2b124a51a9066df1bb106f878_31bf3856ad364e35_6.1.7600.20617_none_c3426f94a8f10ba7.manifest
File versionNot applicable
File size700
Date (UTC)14-Jan-2010
Time (UTC)18:28
PlatformNot applicable
File nameIa64_microsoft-windows-vssservice_31bf3856ad364e35_6.1.7600.20617_none_5b7c192f920c1b63.manifest
File versionNot applicable
File size18,238
Date (UTC)14-Jan-2010
Time (UTC)08:29
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,684
Date (UTC)14-Jan-2010
Time (UTC)18:28
PlatformNot applicable

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References

For more information about the IVssProviderCreateSnapshotSet::PostFinalCommitSnapshots method, visit the following Microsoft Developer Network (MSDN) Web site: For more information about the IVssProviderCreateSnapshotSet::PreFinalCommitSnapshots method, visit the following Microsoft Developer Network (MSDN) Web site:

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Keywords: kbautohotfix, kbfix, kbqfe, kbexpertiseadvanced, kbsurveynew, kbhotfixserver, KB977096

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Article Info
Article ID : 977096
Revision : 2
Created on : 2/24/2010
Published on : 2/24/2010
Exists online : False
Views : 545