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Error message when ISV partners use the AcquirePreLicense method on a computer that is running Windows Server 2008 R2:DirectoryServicesCOMException


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In a multiforest and multidomain environment, there is a contact or a disabled user account.
  • The user domain and the RMS server domain are not the same domain.
  • The AcquirePreLicense method is used by Independent Software Vendor (ISV) partners on a computer that is running Windows Server 2008 R2.
In this scenario, you receive the following error message:
0x8007202B
DirectoryServicesCOMException

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Cause

When the RMS server searches for contacts or for disabled user accounts during an AcquirePreLicense operation, the RMS server incorrectly queries the RMS server domain. Instead, the RMS server should query the domain that contains the contact or the disabled user account.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2008 R2.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.rightsmanagementservices.pipeline.dll6.1.7600.20560278,52828-Oct-200909:35x86

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Workaround

To work around the issue, move all Active Directory accounts into the same domain as the RMS server.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_ef4de7a74d2f156cb5971a8baa9fe84e_31bf3856ad364e35_6.1.7600.20560_none_a0137f7d479fe3da.manifestNot Applicable71628-Oct-200911:13Not Applicable
Msil_microsoft.rightsman..ntservices.pipeline_31bf3856ad364e35_6.1.7600.20560_none_2aa8e25e4d2b6d1f.manifestNot Applicable1,62828-Oct-200910:06Not Applicable
Package_1_for_kb977068~31bf3856ad364e35~amd64~~6.1.1.0.mumNot Applicable1,83128-Oct-200911:13Not Applicable
Package_for_kb977068_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNot Applicable1,45228-Oct-200911:13Not Applicable

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Keywords: kbqfe, kbsurveynew, kbautohotfix, kbexpertiseinter, kbexpertiseadvanced, kbbug, kbfix, kbhotfixserver, KB977068

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Article Info
Article ID : 977068
Revision : 3
Created on : 1/11/2010
Published on : 1/11/2010
Exists online : False
Views : 307